Subsequence 二分搜索

描述
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

#include<stdio.h>
int n,s,a[100005];
bool check(int ans)
{
    int sum=0;
    for(int j=0;j<ans;j++)
        sum+=a[j];
    for(int j=ans;j<=n;j++)
    {
        if(sum>=s)
            return true;//ans一定成立 让top=ans 
        sum+=a[j]-a[j-ans];
    }
    return false;//ans一定不成立 让low=ans 
}
int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            scanf("%d%d",&n,&s);int sum=0,max=-100000; 
            for(int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                if((sum+=a[i])<0) sum=0;
                if(sum>max) max=sum;//记录最大连续片段和 
            }
            if(max<s)//如果 大连续片段和小于 s 显然答案不存在 输出0 
            {
                printf("0\n");
                continue;
            }
            int low=0,top=n;
            while(top-low>1)//寻找满足条件的最小值 
            {
                int m=(top+low)>>1;
                if(check(m))
                    top=m;
                else
                    low=m;
            }
            printf("%d\n",top);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值