The Frog's Games 二分搜索

描述
The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output
For each case, output a integer standing for the frog’s ability at least they should have.
Sample Input
6 1 2
2
25 3 3
11
2
18
Sample Output
4
11

和POJ的 3258 River Hopscotch 有点像

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[500005];int L,N,M;
bool check(int ans)
{
    int last=0,now,m=0;
    while(last<N)
    {
        if(ans+a[last]<L)
        {
            now=upper_bound(a,a+N,ans+a[last])-1-a;
            if(now==last)//相等说明最远跳跃距离内没有石头 那么low=ans 
                return false;
        }
        else
            now=N;
        last=now; 
        m++;
    }
    /*
    m 代表一次最远跳ans的最小次数 
    若m>M说明ans小了   m<M 说明ans大了
    注意m=m 虽然满足条件 但未必是最优解 
    所以 当 m<=M 时 让 top=ans 
    */ 
    return m<=M;
}
int main()
{
    while(~scanf("%d%d%d",&L,&N,&M))
    {
        for(int i=0;i<N;i++)
            scanf("%d",&a[i]);
        a[N++]=0;a[N++]=L;
        sort(a,a+N);
        int low=0,top=L;
        while(top-low>1)//查找满足条件的最小值 注意满足条件有多个 
        {
            int m=(top+low)>>1;
            if(check(m))
                top=m;
            else
                low=m;
        }
        printf("%d\n",top);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值