PAT 1090 Highest Price in Supply Chain (25分)

原题链接:1090 Highest Price in Supply Chain (25分)
关键词:树的遍历

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105​​ ), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010​​ .

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意:
供应链是由零售商,经销商和供应商构成的销售网络,现在,给定整个销售网络,请你计算零售商能达到的最高销售价格。

分析: 这道题我读题的时候就读了半天,一开始输入看不明白……。
整个销售网络可以看作一个树形结构,从根部的供应商往下,只有零售商(即叶节点)可以直接将产品销售给顾客,因此要求出最大的价格,那么相当于求叶子结点的最大高度,和最大高度下有多少叶子结点。

代码:
完成于2020.7.22模拟考 7-3

// 7-3 AC

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5+10;
int N, root, maxh = 1, cnt = 0;
double p, r;
vector<int> child[maxn];

void dfs(int x, int h){
	if(child[x].size() == 0 && maxh < h){
		maxh = h;
		cnt=1;
	}
	else if(h == maxh) cnt++;
	
	for(int i = 0; i < child[x].size(); i ++ ){
		dfs(child[x][i], h+1);
	}
}

int main(){
	scanf("%d %lf %lf", &N, &p, &r);

	for(int i = 0; i < N; i ++ ){
		int temp;
		cin >> temp;
		if(temp == -1) root = i;
		else
			child[temp].push_back(i);
	}

	dfs(root, 1);
	//printf("%d %d", maxh, cnt);
	
	double ans = p*pow((1+r/100), maxh-1);	
	printf("%.2lf %d", ans, cnt);
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值