PAT 1051 Pop Sequence(25分)

原题链接:PAT 1051 Pop Sequence(25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目大意:

有一个最大容量为m的栈,现在给定入栈序列为1,2,3……n,问一下哪些出栈序列是可能的,可能的输出YES,不可能的输出No

方法一:栈+模拟

思路:

C++ 代码:

// pat 1051 Pop Sequence

#include<iostream>
#include<stack>
#include<vector>
using namespace std;

int m, n, k;    // m栈最大容量 n序列长度 k询问数

int main(){
    cin >> m >> n >> k;

    // k个询问
    while(k--){
        bool flag = false;
        vector<int> v(n + 1);
        stack<int> s;

        // 读入出栈序列
        for(int i = 1; i <= n; i++){
            cin >> v[i];
        }

        int current = 1; 

        // 对于1~n, 依次入栈
        for(int j = 1; j <= n; j++){
            s.push(j);
            
            // 超过最大容量就退出
            if(s.size() > m)
                break;

            while(!s.empty() && s.top() == v[current]){
                s.pop();
                current++;
            }
        }

        if(current == n + 1) 
            flag = true;
        
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }

    return 0;
}
  • 5
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值