poj2955(区间dp)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4468 Accepted: 2372

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, imwhere 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source


分析:括号匹配问题,没找到一对括号都把它看成[xxxxxxx]oooooo这种形式,最大匹配数就为xxxxx的匹配数+ooooo的匹配数+2。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
#define ll long long
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;

char str[105];
int dp[105][105];

int main ()
{
    while (gets(str))
    {
        if (strcmp(str, "end")==0)
            break;
        int len = strlen(str);
        for (int i=0; i<len; i++)
            for (int j=0; j<len; j++)
            dp[i][j] = 0;
        for (int i=len-1; i>=0; i--)
        {
            for (int j=i+1; j<len; j++)
            {
                dp[i][j] = max(dp[i+1][j], dp[i][j-1]);
                for (int k=i+1; k<=j; k++)
                {
                    if ((str[i]=='('&&str[k]==')')||(str[i]=='['&&str[k]==']'))
                        dp[i][k] = max(dp[i][k], dp[i+1][k-1]+2);
                    dp[i][j] = max(dp[i][j], dp[i][k]+dp[k+1][j]);
                }
                //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
            }
        }
        printf ("%d\n",dp[0][len-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值