hdu2476(区间dp)

String painter

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2449 Accepted Submission(s): 1095


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output
A single line contains one integer representing the answer.

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd

Sample Output
  
  
6 7

Source

题意:每次只能把一个区间变为同一种字符,求把A串变成B串的最小步数。
分析:先不考虑A串,把由空串变为B串的方案存起来,然后在考虑A串和B串相同字符。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long

char a[105],b[105];
int dp[105][105],ans[105];

int main ()
{
    while (scanf ("%s%s",a,b)!=EOF)
    {
        int n=strlen(a);
        for (int i=0; i<n; i++)
            for (int j=i; j<n; j++)
            dp[i][j] = j-i+1;
        for (int l=0; l<n; l++)
        {
            for (int i=0; i<n&&i+l<n; i++)
            {
                int j=i+l;
                dp[i][j] = dp[i+1][j]+1;
                for (int k=i+1; k<=j; k++)
                {
                    if (b[i] == b[k])
                        dp[i][j]=min(dp[i][j], dp[i+1][k]+dp[k+1][j]);
                }
            }
        }
        //for (int i=0; i<n; i++)
            //cout<<dp[0][i]<<endl;
        if (a[0]==b[0]) ans[0]=0;
        else ans[0]=1;
        for (int i=1; i<n; i++)
        {
            ans[i] = dp[0][i];
            if (a[i]==b[i]) ans[i]=ans[i-1];
            else
            {
                for (int k=0; k<i; k++)
                    ans[i]=min(ans[i], ans[k]+dp[k+1][i]);
            }
            //cout<<ans[i]<<endl;
        }
        printf ("%d\n",ans[n-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值