综合实验(第一阶段学习完成)

r1:
 
[r1]interface g0/0/0                        
[r1-GigabitEthernet0/0/0]ip address 172.16.64.2 18
[r1]interface g0/0/1     
[r1-GigabitEthernet0/0/1]ip address 172.16.0.1 18    
[r1]interface LoopBack 0    
[r1-LoopBack0]ip address 1.1.1.1 32
[r1]ospf 100 router-id 1.1.1.1   
[r1-ospf-100]area 1   
[r1-ospf-100-area-0.0.0.1]network 172.16.64.2 0.0.0.0 
[r1-ospf-100]area 0    
[r1-ospf-100-area-0.0.0.0]network 172.16.0.1 0.0.0.0    
[r1-ospf-100-area-0.0.0.0]network 1.1.1.1 0.0.0.0 
[r1]ospf 100                                 
[r1-ospf-100]area 1
[r1-ospf-100-area-0.0.0.1]authentication-mode simple cipher 123  
[r1-ospf-100]area 0
[r1-ospf-100-area-0.0.0.0]authentication-mode simple cipher 456     
[r1-ospf-100-area-0.0.0.0]authentication-mode md5  
r2: 
[r2]interface g0/0/0                                    
[r2-GigabitEthernet0/0/0]ip address 172.16.0.2 18
[r2]interface g0/0/1    
[r2-GigabitEthernet0/0/1]ip address 172.16.128.2 18    
[r2]interface LoopBack 0    
[r2-LoopBack0]ip address 2.2.2.2 32
[r2]ospf 100 router-id 2.2.2.2                         
[r2-ospf-100]area 0    
[r2-ospf-100-area-0.0.0.0]network 172.16.0.2 0.0.0.0
[r2-ospf-100-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[r2-ospf-100]area 2    
[r2-ospf-100-area-0.0.0.2]network 172.16.128.2 0.0.0.0
[r2]ospf 100                           
[r2-ospf-100]area 0
[r2-ospf-100-area-0.0.0.0]authentication-mode simple cipher 456
[r2-ospf-100-area-0.0.0.0]authentication-mode md5
[r2]ospf 100                                      
[r2-ospf-100]area 2    
[r2-ospf-100-area-0.0.0.2]authentication-mode simple cipher 789
r3: 
[r3]interface g0/0/0                                  
[r3-GigabitEthernet0/0/0]ip address 172.16.0.3 18
[r3]interface g0/0/1    
[r3-GigabitEthernet0/0/1]ip address 172.16.192.1 18
[r3]interface LoopBack 0
[r3-LoopBack0]ip address 3.3.3.3 32
[r3]ospf 100 router-id 3.3.3.3                
[r3-ospf-100]area 0    
[r3-ospf-100-area-0.0.0.0]network 172.16.0.3 0.0.0.0    
[r3-ospf-100-area-0.0.0.0]network 3.3.3.3 0.0.0.0    
[r3]ospf 100 router-id 3.3.3.3
[r3-ospf-100]area 3    
[r3-ospf-100-area-0.0.0.3]network 172.16.192.1 0.0.0.0
[r3]ospf 100                               
[r3-ospf-100]area 0    
[r3-ospf-100-area-0.0.0.0]authentication-mode simple cipher 456
[r3-ospf-100-area-0.0.0.0]authentication-mode md5
[r3]ospf 100                                      
[r3-ospf-100]area 3    
[r3-ospf-100-area-0.0.0.3]authentication-mode simple cipher 14
r4:
 [r4]interface g0/0/0                                   
[r4-GigabitEthernet0/0/0]ip address 172.16.192.2 18    
[r4]interface LoopBack 0    
[r4-LoopBack0]ip address 4.4.4.4 32
[r4]ospf 100 router-id 4.4.4.4                      
[r4-ospf-100]area 3    
[r4-ospf-100-area-0.0.0.3]network 0.0.0.0 255.255.255.255
[r4]ospf 100                                         
[r4-ospf-100]area 3
[r4-ospf-100-area-0.0.0.3]authentication-mode simple cipher 147
r6:
[r6]interface g0/0/0                       
[r6-GigabitEthernet0/0/0]ip address 10.1.1.2 24
[r6]interface g0/0/1    
[r6-GigabitEthernet0/0/1]ip address 172.16.64.1 18    
[r6]interface LoopBack 0    
[r6-LoopBack0]ip address 6.6.6.6 32 
[r6]ospf 100 router-id 6.6.6.6                 
[r6-ospf-100]area 1    
[r6-ospf-100-area-0.0.0.1]network 0.0.0.0 255.255.255.255
[r6]ospf 100                             
[r6-ospf-100]area 1    
[r6-ospf-100-area-0.0.0.1]authentication-mode simple cipher 123
r8:                                              
[r8]interface g0/0/0                                   
[r8-GigabitEthernet0/0/0]ip address 172.16.128.1 18    
[r8]interface LoopBack 0    
[r8-LoopBack0]ip address 8.8.8.8 32 
[r8]ospf 100 router-id 8.8.8.8                  
[r8-ospf-100]area 2    
[r8-ospf-100-area-0.0.0.2]network 0.0.0.0 255.255.255.255
 8]ospf 100                                        
[r8-ospf-100]area 2    
[r8-ospf-100-area-0.0.0.2]authentication-mode simple cipher 789
r1:
[r1]interface g0/0/0                           
[r1-GigabitEthernet0/0/0]ospf timer hello 5   
[r1]interface g0/0/1
[r1-GigabitEthernet0/0/1]ospf timer hello 5
r2:
[r1]interface g0/0/0                               
[r1-GigabitEthernet0/0/0]ospf timer hello 5
[r1]interface g0/0/1
[r1-GigabitEthernet0/0/1]ospf timer hello 5
r3:
[r3]interface g0/0/0                               
[r3-GigabitEthernet0/0/0]ospf timer hello 5
[r3]interface g0/0/1
[r3-GigabitEthernet0/0/1]ospf timer hello 5
r4: 
[r4]interface g0/0/0                              
[r4-GigabitEthernet0/0/0]ospf timer hello 5
r6: 
[r6]interface g0/0/1                         
[r6-GigabitEthernet0/0/1]ospf timer hello 5
r8: 
[r8]interface g0/0/0                              
[r8-GigabitEthernet0/0/0]ospf timer hello 5
[r6]interface g0/0/1                          
[r6-GigabitEthernet0/0/1]ospf dr-priority 0 
r2:
[r2]interface g0/0/0                                    
[r2-GigabitEthernet0/0/0]ospf dr-priority 0
r3:
[r3]interface g0/0/0                               
[r3-GigabitEthernet0/0/0]ospf dr-priority 0
LSW2:
[Huawei]vlan 2 
[Huawei]vlan 3   
[Huawei]interface e0/0/2   
[Huawei-Ethernet0/0/2]port link-type access
[Huawei-Ethernet0/0/2]port default vlan 2 
[Huawei]interface e0/0/3    
[Huawei-Ethernet0/0/3]port link-type access     
[Huawei-Ethernet0/0/3]port default vlan 3

r8:
   
[r8]dhcp enable
[r8]interface g0/0/1.1   
[r8-GigabitEthernet0/0/1.1]dot1q termination vid 2  
[r8-GigabitEthernet0/0/1.1]ip address 192.168.1.1 24
[r8]ip pool 1   
[r8-ip-pool-1]network 192.168.1.0 mask 255.255.255.0
[r8-ip-pool-1]gateway-list 192.168.1.1   
[r8-ip-pool-1]dns-list 8.8.8.8 
[r8]interface g0/0/1.1                          
[r8-GigabitEthernet0/0/1.1]dhcp select global     
[r8-GigabitEthernet0/0/1.1]arp broadcast enable     
[r8]interface g0/0/1.2                          
[r8-GigabitEthernet0/0/1.2]dot1q termination vid 3    
[r8-GigabitEthernet0/0/1.2]ip address 192.168.2.1 24
[r8]ip pool 2                                  
[r8-ip-pool-2]network 192.168.2.0 mask 255.255.255.0    
[r8-ip-pool-2]gateway-list 192.168.2.1
[r8-ip-pool-2]dns-list 8.8.8.8 
[r8]interface g0/0/1.2                                                  
[r8-GigabitEthernet0/0/1.2]dhcp select global     
[r8-GigabitEthernet0/0/1.2]arp broadcast enable 
LSW2: 
[Huawei]interface e0/0/1                        
[Huawei-Ethernet0/0/1]port link-type trunk     
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan  LSW3: 
[Huawei]vlan 4              
[Huawei]vlan 5
[Huawei]interface 0/0/2                          
[Huawei-Ethernet0/0/2]port link-type access     
[Huawei-Ethernet0/0/2]port default vlan 4    
[Huawei]interface e0/0/3    
[Huawei-Ethernet0/0/3]port link-type access     
[Huawei-Ethernet0/0/3]port default vlan 5

r4 
[r4]dhcp enable                                       
[r4]interface g0/0/1.1                                  
[r4-GigabitEthernet0/0/1.1]dot1q termination vid 4    
[r4-GigabitEthernet0/0/1.1]ip address 192.168.3.1 24
[r4]ip pool 3                                        
[r4-ip-pool-3]network 192.168.3.0 mask 255.255.255.0    
[r4-ip-pool-3]gateway-list 192.168.3.1
[r4-ip-pool-3]dns-list 8.8.8.8
[r4]interface g0/0/1.1                                      
[r4-GigabitEthernet0/0/1.1]dhcp select global     
[r4-GigabitEthernet0/0/1.1]arp broadcast enable 
[r4]interface g0/0/1.2                             
[r4-GigabitEthernet0/0/1.2]dot1q termination vid 5    
[r4-GigabitEthernet0/0/1.2]ip address 192.168.4.1 24
[r4]ip pool 4                                         
[r4-ip-pool-4]network 192.168.4.0 mask 255.255.255.0
[r4-ip-pool-4]gateway-list 192.168.4.1
[r4-ip-pool-4]dns-list 8.8.8.8
[r4]interface g0/0/1.2                                      
[r4-GigabitEthernet0/0/1.2]dhcp select global     
[r4-GigabitEthernet0/0/1.2]arp broadcast enable 


LSW3:
 
[Huawei]interface e0/0/1                       
[Huawei-Ethernet0/0/1]port link-type trunk     
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all

r6:
 
[r6]acl 2000                                  
[r6-acl-basic-2000]rule permit source any
[r6]interface g0/0/0    
[r6-GigabitEthernet0/0/0]nat outbound 2000
 
    
[r6]ip route-static 0.0.0.0 0 10.1.1.1        
[r6]ospf 100    
[r6-ospf-100]default-route-advertise   
r7:
 
[r7]interface g0/0/0                                
[r7-GigabitEthernet0/0/0]ip address 11.1.1.1 24
[r7]interface g0/0/1    
[r7-GigabitEthernet0/0/1]ip address 10.1.1.1 24
 
 
[r7]ip route-static 172.16.64.0 18 10.1.1.2     
[r7]ip route-static 172.16.0.0 18 10.1.1.2
[r7]ip route-static 172.16.128.0 18 10.1.1.2
[r7]ip route-static 192.168.1.0 24 10.1.1.2
[r7]ip route-static 192.168.2.0 24 10.1.1.2
[r7]ip route-static 192.168.3.0 24 10.1.1.2
[r7]ip route-static 192.168.4.0 24 10.1.1.2
[r7]ip route-static 172.16.192.0 18 10.1.1.2

r7:
 
[r7]aaa                                   
[r7-aaa]local-user 11 privilege level 15 password cipher 22
[r7]user-interface vty 0 4    
[r7-ui-vty0-4]authentication-mode aaa
 
[r7]interface g0/0/1                 
[r7-GigabitEthernet0/0/1]nat server protocol tcp global 11.1.1.3 23 inside 172.1
6.192.2 23                

r3:
 
[r3]acl 3000
[r3-acl-adv-3000]rule deny tcp source 192.168.3.1 0.0.0.0 destination 172.16.64.1 0.0.
0.0 destination-port eq telnet 
[r3-acl-adv-3000]rule permit ip source any destination any 
 
[r3]interface g0/0/1                   
[r3-GigabitEthernet0/0/1]traffic-filter inbound acl 3000

r4:
 
[r4]acl 3000                    
[r4-acl-adv-3000]rule deny icmp source 192.168.4.1 0.0.0.0 destination 192.168.2
.1 0.0.0.0 icmp-type echo
[r4-acl-adv-3000]rule permit ip source any destination any
[r4]interface g0/0/1                  
[r4-GigabitEthernet0/0/1]traffic-filter inbound 3000

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值