HDU - 5536 Chip Factory(暴力)

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the ii -th chip produced this day has a serial number sisi .

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

maxi,j,k(si+sj)skmaxi,j,k(si+sj)⊕sk


which i,j,ki,j,k are three different integers between 11 and nn . And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?InputThe first line of input contains an integer TT indicating the total number of test cases.

The first line of each test case is an integer nn , indicating the number of chips produced today. The next line has nn integers s1,s2,..,sns1,s2,..,sn , separated with single space, indicating serial number of each chip.

1T10001≤T≤1000
3n10003≤n≤1000
0si1090≤si≤109
There are at most 1010 testcases with n>100n>100
OutputFor each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400
思路:这道题是到暴力题,但是也不能瞎暴力,要注意在n^3复杂度下做些优化,比如有些数值会重复计算,这会导致时间过长。需要在符合i != j && i != k && k != j 情况下,使某个值与后面那些未出现过的值进行运算,这就降低了时间复杂度。
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

int t, n, s[1000+8], sum;

int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        sum = 0;
        for(int i = 0; i<n; i++)
            scanf("%d", &s[i]);
        for(int i = 0; i<n; i++)
            for(int j = i+1; j<n; j++)
                for(int k = j+1; k<n; k++)
                {
                    int ying = (s[i]+s[j])^s[k];
                    int miao = (s[j]+s[k])^s[i];
                    int wang = (s[i]+s[k])^s[j];
                    if(ying>sum) sum = ying;
                    if(miao>sum) sum = miao;
                    if(wang>sum) sum = wang;
                }
        printf("%d\n", sum);
    }
    return 0;
}
 
 

 

 

 

转载于:https://www.cnblogs.com/RootVount/p/10908141.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值