Chip Factory(HDU-5536)

Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the i-th chip produced this day has a serial number si. 

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below: 

max_{i,j,k}(si+sj)  ⊕ sk

which i,j,ki,j,k are three different integers between 1 and nn. And ⊕ is symbol of bitwise XOR. Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer TT indicating the total number of test cases. 

The first line of each test case is an integer nn, indicating the number of chips produced today. The next line has nn integers s1,s2,..,sn, separated with single space, indicating serial number of each chip. 

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 1010 testcases with n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

题意:t 组数据,每组给出 n 个数 si,求 max_{i,j,k}(si+sj)  ⊕ sk,其中 1<=i<=n

思路:01字典树的题,但暴搜也可以做,需要注意暴搜的技巧,不然会 TLE

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 1000003
#define INF 0x3f3f3f3f
#define N 1001
#define LL long long
using namespace std;
int n;
int s[N];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(s,0,sizeof(s));

        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);

        int maxx=-INF;
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                for(int k=j+1;k<n;k++){
                    maxx=max(maxx,((s[i]+s[j])^s[k]));
                    maxx=max(maxx,((s[i]+s[k])^s[j]));
                    maxx=max(maxx,((s[j]+s[k])^s[i]));
                }
            }
        }

        printf("%d\n",maxx);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值