hdu 5536 Chip Factory(字典树)

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the ii-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk
which i,j,ki,j,k are three different integers between 1 and nn. And ⊕is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?
Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn,separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤1e9≤si≤1e9
There are at most 10 testcases with n>100
Output
For each test case, please output an integer indicating the checksum number in a line.
Sample Input
2
3
1 2 3
3
100 200 300
Sample Output
6
400

题意:给出一个数组,求(si+sj)⊕sk最大值,i,j,k不能相同
同样用字典树解决,既然要求i,j,k不能相同,那就直接往字典树中插入sk,遍历ij,删去字典树中的sisj,然后刷新最大值,刷新最大值同样也是,然后再插入sisj即可
#include<bits/stdc++.h>
using namespace std;
struct node
{
    int val;
    node *next[2];
    node()
    {
        val=0;
        next[0]=next[1]=NULL;
    }
};
node *root;
int a[1005];
void trie_add(int num)
{
    node *p=root;
    for(int i=31;i>=0;i--)
    {
        int id=((num&(1<<i))!=0);
        if(p->next[id]==NULL)
        p->next[id]=new node();
        p=p->next[id];
        p->val++;
    }
}
void trie_delete(int num)
{
    node *p=root;
    for(int i=31;i>=0;i--)
    {
        int id=((num&(1<<i))!=0);
            p=p->next[id];
            p->val--;
    }
}
int trie_query(int num)
{
    node *p=root;
    int ans=num;
    for(int i=31;i>=0;i--)
    {
        int id=((num&(1<<i))!=0);
        if(p->next[id^1]!=NULL&&p->next[id^1]->val)
        {
            ans^=((id^1)<<i);
            p=p->next[id^1];
        }
        else
        {
            ans^=(id<<i);
            p=p->next[id];
        }
    }
    return ans;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        root=new node();
       scanf("%d",&n);
       for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            trie_add(a[i]);
        }
        int maxx=0;
       for(int i=0;i<n;i++)
       {
           for(int j=i+1;j<n;j++)
           {
               trie_delete(a[i]);
               trie_delete(a[j]);
               maxx=max(maxx,trie_query(a[i]+a[j]));
               trie_add(a[i]);
               trie_add(a[j]);
           }
       }
        printf("%d\n",maxx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值