uva 1347 tour

这是一个经典的DP最长路问题

下面是问题描述和我写的题解~~

ps:这是我目前为止第一个一次编译通过的DP代码~~
第一次很有意义的哦

Description

John Doe, a skilled pilot, enjoys traveling. While on vacation, he
rents a small plane and starts visiting beautiful places. To save
money, John must determine the shortest closed tour that connects his
destinations. Each destination is represented by a point in the plane
pi = < xi,yi >. John uses the following strategy: he starts from the
leftmost point, then he goes strictly left to right to the rightmost
point, and then he goes strictly right back to the starting point. It
is known that the points have distinct x-coordinates. Write a program
that, given a set of n points in the plane, computes the shortest
closed tour that connects the points according to John’s strategy.
Input The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the
data set contains the number of points, and the point coordinates in
ascending order of the x coordinate. White spaces can occur freely in
input. The input data are correct.
Output For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length,
a floating-point number with two fractional digits, represents the
result. An input/output sample is in the table below. Here there are
two data sets. The first one contains 3 points specified by their x
and y coordinates. The second point, for example, has the x coordinate
2, and the y coordinate 3. The result for each data set is the tour
length, (6.47 for the first data set in the given example).
Sample Input 3 1 1 2 3 3 1 4 1 1 2 3 3 1 4 2
Sample Output
6.47
7.89

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;

const int maxn = 1000+10;
double d[maxn][maxn],dist[maxn][maxn];

struct point
{
    int x;
    int y; 
}p[maxn];

int main()
{
    int n;
    cin >> n;
    for(int i = 1 ; i <= n ; i++ )
        cin >> p[i].x >> p[i].y;
    for(int i = 1 ; i <= n ; i++ )
        for(int j = 1; j <= n ; j++)
            dist[i][j] = dist[j][i] =(double)sqrt(pow(p[i].x-p[j].x,2)+(pow(p[i].y-p[j].y,2));
    for(int i = 1 ; i <= n-2 ; i++)
        d[n-1][i] = dist[n-1][n] + dist[i][n];
    for(int i = n-2 ; i >= 2 ; i-- )
        for(int j = 1 ; j < i ; j++)
            d[i][j] = min(d[i+1][j]+dist[i][i+1],d[i+1][i]+dist[i+1][j]);
    printf("%.2f",d[2][1]+dist[2][1]);
    return 0;   
}

中间可能有的语句太长打弯了~见谅~

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值