hdu5240——Exam(贪心)

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1922    Accepted Submission(s): 941


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
 

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
  
  
Case #1: NO Case #2: YES
 
给出若干门课的通过需要复习的时间,考试开始时间和考试持续时间,求这个人能否参加和通过所有考试;
排序贪心解决(考试得一门一门的来,所以按照开始时间排序,开始时间相同就按复习时间来,即优先准备靠的近的考试),看是否有重合的区间。有就NO,没有就YES
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <stack>
using namespace std;
typedef long long ll;
#define PI 3.1415926535897932
#define E 2.718281828459045
#define INF 0xffffffff//0x3f3f3f3f
#define mod 100
const int M=1005;
int n,m;
int cnt;
int sx,sy,sz;
int mp[1000][1000];
int pa[M*10],rankk[M];
int head[M*6],vis[M*100];
int dis[M*100];
int prime[M*1000];
bool isprime[M*1000];
int lowcost[M],closet[M];
char st1[5050],st2[5050];
//int len[M*6];
typedef pair<int ,int> ac;
int dp[55][55][55][55];
int has[1050000];
int month[13]= {0,31,59,90,120,151,181,212,243,273,304,334,0};
int dir[8][2]= {{0,1},{0,-1},{-1,0},{1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
void getpri()
{
    int i;
    int j;
    cnt=0;
    memset(isprime,false,sizeof(isprime));
    for(i=2; i<1005; i++)
    {
        if(!isprime[i])prime[cnt++]=i;
        for(j=0; j<cnt&&prime[j]*i<10000; j++)
        {
            isprime[i*prime[j]]=1;
            if(i%prime[j]==0)break;
        }
    }
}
struct node
{
    int r,e,l;
};
bool cmp(node a,node b){
    if(a.e!=b.e)
    return a.e<b.e;
    return a.r<b.r;
}
vector<int> g[100005];
char str[10005];
int bit[50];
node num[100005];
int main()
{
    int t,i,j,k;
    int cas =0 ;
    scanf("%d",&t) ;
    while(t--)
    {
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d%d%d",&num[i].r,&num[i].e,&num[i].l);
        }
        sort(num,num+n,cmp);
        k=0;bool flag=1;
        for(i=0;i<n;i++){
            if(num[i].r+k<=num[i].e)//复习完在考试前
            {
                k=num[i].e+num[i].l;//准备下一门
            }
            else {
                flag=false;break;//捉襟见肘了
            }
        }
        if(flag)
        {
            printf("Case #%d: YES\n",++cas);
        }
        else
        {
            printf("Case #%d: NO\n",++cas);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值