SDKD 2017 Spring Team Training A---E - Exam

As this term is going to end, DRD needs to prepare for his final exams. 

DRD has  n n exams. They are all hard, but their difficulties are different. DRD will spend at least  ri ri hours on the  i i-th course before its exam starts, or he will fail it. The  i i-th course's exam will take place  ei ei hours later from now, and it will last for  li li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
Input
First line: an positive integer  T20 T≤20 indicating the number of test cases. 
There are T cases following. In each case, the first line contains an positive integer  n105 n≤105, and  n n lines follow. In each of these lines, there are 3 integers  ri,ei,li ri,ei,li, where  0ri,ei,li109 0≤ri,ei,li≤109

Output
For each test case: output ''Case #x: ans'' (without quotes), where  x x is the number of test cases, and  ans ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2
Sample Output
Case #1: NO
Case #2: YES
解题思路:

n门课程,每门课有r,e,l分别为需要准备复习时间,考试时间,考试持续时间,考试时不能复习,复习时间是不连续的,求能否通过考试,要对考试结构数组按考试开始时间排序,对每门课进行判断

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
struct test
{
	int r,e,l;
};
int comp(const test &a,const test &b)
{
	if(a.e<b.e)	return 1;
	if(a.e>b.e)	return 0;
	if(a.r<b.r)	return 1;
}
int main()
{
    //freopen("aaa.txt","r",stdin);
	int t,n,i,j,num=0;;
	test te[100000];
	cin>>t;
	while(t--)
	{
		memset(te,0,sizeof(te));
		num++;
		cin>>n;
		int flag=0;
		for(i=0;i<n;i++)
		{
			cin>>te[i].r>>te[i].e>>te[i].l;;
			if(te[i].r>te[i].e)
				flag=1;
		}

		if(flag==0)
		{
		    //sort(te,te+n,comp);
			int time=te[0].r+te[0].l;//这两句可以调换次序 ?????
			sort(te,te+n,comp);
			for(i=1;i<n;i++)
			{
				if(te[i].e>=time+te[i].r)
					time+=(te[i].r+te[i].l);
				else
				{
					flag=1;
					break;
				}
			}
		}
		if(flag==1)
			cout<<"Case #"<<num<<": NO"<<endl;
		else
			cout<<"Case #"<<num<<": YES"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值