Can you answer these queries?

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

分析

线段树。
注意:更新时需开根号取整数。
特判1 很重要,避免超时。(tree[rt]==r-l+1)

Runtime Error“ACCESS_VIOLATION”第一次遇到这个错误。非法访问。
1.刚开始遇到这个错误,百度了一下,,有人说 查询区间时题目中l不一定大于r 我改了 然后还是这个错误。
2.然后审题,发现数组开小了,改了又交了一次,PE。
3.最后再研究了一下,每组数据结束还有个换行符。加上。ac了。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define ll long long
const int N = 1e5 + 10;
int top;


ll tree[N<<2];
ll a[N];

void pushup(int rt){
    tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
}
void build(int rt,int l,int r){
    if(l==r){
        tree[rt] = a[l];
        // printf("%d: %lld\n", rt, tree[rt]);
        return;
    }
    int mid = (l + r) >> 1;
    build(rt << 1, l, mid);
    build(rt << 1|1, mid + 1, r);
    pushup(rt);
}

void update(int rt,int l,int r,int x,int y){
    if(tree[rt]==r-l+1)//避免超时
        return;
    // if (x <= l && r <= y){   //不清楚为什么要精确搜索到点。
    //     tree[rt] = (ll)sqrt(tree[rt]);
    //     return;
    // }
    if(l==r){
        tree[rt] = (ll)sqrt(tree[rt]);
        return;
    }
    int mid = (l + r) >> 1;
    if(x<=mid)
        update(rt << 1, l, mid, x, y);
    if(y>mid)
        update(rt << 1 | 1, mid + 1, r, x, y);
    pushup(rt);
}
ll query(int rt,int l,int r,int x,int y){
    if(x<=l&&r<=y){
        return tree[rt];
    }
    int mid = (l + r) >> 1;
    ll ans = 0;
    if (x <= mid)
        ans += query(rt << 1, l, mid, x, y);
    if(y>mid)
        ans += query(rt << 1 | 1, mid + 1, r, x, y);
    return ans;
}

int main()
{
    int n,m,j;
    int t,x,y;
    int h = 1;
    while (scanf("%d", &n)!=EOF)
    {
        printf("Case #%d:\n", h++);
        for (int i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        build(1,1,n);
        scanf("%d", &m);
        while(m--){
            scanf("%d%d%d", &t, &x, &y);
            if(x>y)
                swap(x, y);
            if (t == 0)
            {
                update(1, 1, n, x, y);
                // printf("%d===%d\n", m, tree[1]);
            }
            else
            {
                printf("%lld\n", query(1, 1, n, x, y));
            }
        }
        puts("");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值