Beautiful People ZOJ - 2319

The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties of Mr Y, he doesn��t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively (1 <= Si, Bi <= 109).

Output
On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in arbitrary order. If several solutions exist, output any one.

Sample Input
1

4
1 1
1 2
2 1
2 2

Sample Output
2
1 4

题意 :求最长的S和B都单调递增的子序列

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<queue>
#include<math.h>
#include<vector>
#include<iostream>
#define inf 0x3f3f3f3f
#define ll long long
#define N 100000+10
using namespace std;
struct node
{
    int x;
    int s,b;
}a[N];
bool cmp(node n1,node n2)
{
    if(n1.s==n2.s)
        return n1.b>n2.b;//让b小的能覆盖b大的
    return n1.s<n2.s;
}
int dp[N];
int mark[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].s,&a[i].b);
            a[i].x=i;
        }
        memset(dp,inf,sizeof(dp));
        sort(a+1,a+1+n,cmp);
        int k=0;
        for(int i=1;i<=n;i++)
        {
            int j=lower_bound(dp+1,dp+1+n,a[i].b)-dp;
            dp[j]=a[i].b;
            mark[i]=j;
            k=max(k,j);
        }
        printf("%d\n",k);
        for(int i=n; i>=1; i--)
        {
            if (mark[i]==k)
            {
                printf("%d ",a[i].x);
                k--;
            }
        }
        printf("\n");
        if(T!=0)
        {
            printf("\n");
        }
    }
}

若是求最长的不减子序列(等于也行)

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<queue>
#include<math.h>
#include<vector>
#include<iostream>
#define inf 0x3f3f3f3f
#define ll long long
#define N 100000+10
using namespace std;
struct node
{
    int x;
    int s,b;
}a[N];
bool cmp(node n1,node n2)
{
    if(n1.s==n2.s)
        return n1.b<n2.b;
    return n1.s<n2.s;
}
int dp[N];
int mark[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].s,&a[i].b);
            a[i].x=i;
        }
        memset(dp,inf,sizeof(dp));
        sort(a+1,a+1+n,cmp);
        int k=0;
        for(int i=1;i<=n;i++)
        {
            int j=upper_bound(dp+1,dp+1+n,a[i].b)-dp;
            dp[j]=a[i].b;
            mark[i]=j;
            k=max(k,j);
        }
        printf("%d\n",k);
        for(int i=n; i>=1; i--)
        {
            if (mark[i]==k)
            {
                printf("%d ",a[i].x);
                k--;
            }
        }
        printf("\n");
        if(T!=0)
        {
            printf("\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值