HDU2586How far away ?

Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#define eps 1e-8
#define ll long long
const int inf = 0x3f3f3f3f;
const long long mod=1e9+7;
const int N=40000+20;
using namespace std;
struct node
{
    int v,c;
}tmp;
vector<node>q[N];
vector<node>e[N];
int n,m,t;
int fa[N],sum[N],vis[N],ans[N];
void init()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        fa[i]=i;
}
int find(int x)
{
    while(x!=fa[x])
        x=fa[x];
    return x;
}
int dfs(int u,int pre,int val)
{
    sum[u]=val;
    int sz=e[u].size();
    for(int i=0;i<sz;i++)
    {
        int v=e[u][i].v;
        int c=e[u][i].c;
        if(v==pre)
            continue;
        dfs(v,u,val+c);
        fa[v]=u;
    }
    int dsz=q[u].size();
    for(int i=0;i<dsz;i++)
    {
        int v=q[u][i].v;
        if(vis[v])
        {
            int c=q[u][i].c;
            int aim=find(v);
            ans[c]=sum[u]+sum[v]-2*sum[aim];
        }
    }
    vis[u]=1;
}
int main()
{
    int u,v,c;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d%d",&n,&m);
    init();
    for(int i=1;i<n;i++)
    {
        scanf("%d%d%d",&u,&v,&c);
        tmp.v=v,tmp.c=c;
        e[u].push_back(tmp);
        tmp.v=u;
        e[v].push_back(tmp);
    }
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&u,&v);
        tmp.v=v,tmp.c=i;
        q[u].push_back(tmp);
        tmp.v=u;
        q[v].push_back(tmp);
    }
    dfs(1,-1,0);
    for(int i=1;i<=m;i++)
        printf("%d\n",ans[i]);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值