Max Sum

Given a sequence a 1 1,a 2 2,a 3 3......a n n, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:

7 1 6

代码如下:

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<iostream>
using namespace std;
#include<stdio.h>
int main()
{
    int i,ca=1,t,L,R,n,x,a,b,max;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a);
            if(i==1)
            {
                max=b=a;
                x=L=R=1;
            }
            else
            {
                if(a>a+b)
                {
                    b=a;
                    x=i;
                }
                else b+=a;
            }
            if(b>max)
                max=b,L=x,R=i;
        }
        printf("Case %d:\n%d %d %d\n",ca++,max,L,R);
        if(t)printf("\n");
    }
    return 0;
}



在下不才,还有另外一种更为简单的方法:

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
    int T,q=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,L=1,R=1,a,sum=0,maxx=-1e9,p=1;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a);
            sum+=a;
            if(sum>maxx)
            {
                maxx=sum;
                R=i;
                L=p;
            }
            if(sum<0)
            {
                sum=0;
                p=i+1;
            }

        }
        printf("Case %d:\n%d %d %d\n",q++,maxx,L,R);
        if(T)
            printf("\n");
    }
}


接下来这一种是十分好理解的一种代码

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<algorithm>
#include<math.h>
using namespace std;
int a[100004];
int main()
{
    int T;
    scanf("%d",&T);
    int q=1;
    while(T--)
    {
        memset(a,0,sizeof(a));
        int n,flag=0;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=0)
                flag=1;
        }
        if(!flag)
        {
            printf("%d 1 1\n",a[1]);
            continue;
        }
        else
        {
            int sum=0,maxx=-1;
            int L=1,R=1;
            int LQ=1,RQ=1;
            for(int i=1; i<=n; i++)
            {
                sum+=a[i];
                R=i;
                if(sum<0)
                {
                    sum=0;
                    L=i+1;
                }
                if(sum>maxx)
                {
                    maxx=sum;
                    LQ=L;
                    RQ=R;
                }
            }
            printf("Case %d:\n%d %d %d\n",q++,maxx,LQ,RQ);
            if(T)
                printf("\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值