Who Says a Pun?(Hash+二分)

Who Says a Pun?(Hash+二分)

题目描述
Find the maximum length of a non-empty string that occurs twice or more in S as contiguous substrings without overlapping.
More formally, find the maximum positive integer len such that there exist integers l1 and l2 ( 1≤l 1,l 2≤N−len+1 ) that satisfy the following:
·l 1+len≤l2
·S[l 1+i]=S[l 2+i](i=0,1,…,len−1)
If there is no such integer len, print 0.
Constraints
·2≤N≤5×10 3
·|S|=N
·S consists of lowercase English letters.
输入
Input is given from Standard Input in the following format:

N
S

输出
Print the maximum length of a non-empty string that occurs twice or more in S as contiguous substrings without overlapping. If there is no such non-empty string, print 0 instead.
样例输入 Copy
【样例1】
5
ababa
【样例2】
2
xy
【样例3】
13
strangeorange
样例输出 Copy
【样例1】
2
【样例2】
0
【样例3】
5
提示
样例1解释
The strings satisfying the conditions are: a, b, ab, and ba. The maximum length among them is 2, which is the answer. Note that aba occurs twice in S as contiguous substrings, but there is no pair of integers l1 and l2 mentioned in the statement such that l1+len≤l2.
样例2解释
No non-empty string satisfies the conditions.
题意:求一个字符串出现次数大于等于2的,最大长度。
思路:二分长度,hash判断是否出现次数大于等于2.
#pragma GCC optimize(3 , "Ofast" , "inline")
 
#include <bits/stdc++.h>
 
#define rep(i , a , b) for(register int i=(a);i<=(b);i++)
#define rop(i , a , b) for(register ll i=(a);i<(b);i++)
#define per(i , a , b) for(register ll i=(a);i>=(b);i--)
#define por(i , a , b) for(register ll i=(a);i>(b);i--)
 
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<ll , ll> pi;
const int maxn = 1e6 + 10;
const int p = 131;
char s[maxn];
ull h[maxn];
ull base[maxn];
int n;
 
template<class T>
inline void read (T &x) {
    x = 0;
    int sign = 1;
    char c = getchar ();
    while (c < '0' || c > '9') {
        if ( c == '-' ) sign = - 1;
        c = getchar ();
    }
    while (c >= '0' && c <= '9') {
        x = x * 10 + c - '0';
        c = getchar ();
    }
    x = x * sign;
}
 
void init() {
    int len  = strlen (s+1);
    base[0]=1;
    h[0]=0;
    rep (i,1,len) {
        h[i]=h[i-1]*p+s[i]-'a'+1;
        base[i]=base[i-1]*p;
    }
}
 
ull getlr(ll l,ll r) {
    return h[r]-h[l-1]*base[r-l+1];
}
 
 
bool check(int mid) {
    int cnt = 1;
    rep (i,1,n-mid+1) {
        ull x = getlr (i,mid+i-1);
        cnt = 1;
        rep (j,i+mid,n-mid+1) {
            ull y = getlr (j,j+mid-1);
            if (x==y) {
                ++cnt;
                if (cnt>=2)
                    return true;
            }
        }
    }
    return false;
}
int main () {
    read (n);
    scanf ("%s",s+1);
    init();
    int ans = 0;
    int l = 1,r = n;
    while (l<=r) {
        int mid = (l+r)/2;
        if(check(mid)) {
            ans=mid,l=mid+1;
        }
        else r=mid-1;
    }
    cout<<ans<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值