题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2108
题目
Problem Description
话说上回讲到海东集团推选老总的事情,最终的结果是XHD以微弱优势当选,从此以后,“徐队”的称呼逐渐被“徐总”所取代,海东集团(HDU)也算是名副其实了。
创业是需要地盘的,HDU向钱江肉丝高新技术开发区申请一块用地,很快得到了批复,据说这是因为他们公司研发的“海东牌”老鼠药科技含量很高,预期将占全球一半以上的市场。政府划拨的这块用地是一个多边形,为了描述它,我们用逆时针方向的顶点序列来表示,我们很想了解这块地的基本情况,现在请你编程判断HDU的用地是凸多边形还是凹多边形呢?
Input
输入包含多组测试数据,每组数据占2行,首先一行是一个整数n,表示多边形顶点的个数,然后一行是2×n个整数,表示逆时针顺序的n个顶点的坐标(xi,yi),n为0的时候结束输入。
Output
对于每个测试实例,如果地块的形状为凸多边形,请输出“convex”,否则输出”concave”,每个实例的输出占一行。
Sample Input
4
0 0 1 0 1 1 0 1
0
Sample Output
convex
海东集团终于顺利成立了!后面的路,他们会顺顺利利吗?
欲知后事如何,且听下回分解——
代码
#include<iostream>
#include<cstdio>
#include<cstring>
//#include<vector>
#include<algorithm>
#define U_DEBUG
#define L_JUDGE
#ifdef L_JUDGE
#pragma warning(disable:4996)
#endif
using namespace std;
const int MAXN=2e5+10;
class Pt{
public:
int x;
int y;
}
Pt pts[MAXN];
int N;
int ustack[MAXN];
int top;
void Init(){
top=-1;
}
void Push(int x){
top++;
ustack[top]=x;
}
int Pop(){
int ret=ustack[top];
top--;
return ret;
}
int main(){
#ifdef L_JUDGE
freopen("in.txt","r",stdin);
// freopen("out.txt","w",stdout);
#endif
while(scanf("%d",&N),N){
Init();
int minyi=0;
for(int i=0;i<N;i++){
scanf("%d%d",&pts[i].x,&pts[i].y);
if(pts[i].y<pts[i])
}
if(flag){
printf("Convex\n");
}else{
printf("Concave\n");
}
}
#ifdef L_JUDGE
fclose(stdin);
fclose(stdout);
system("out.txt");
#endif
return 0;
}