1127. ZigZagging on a Tree (30)

389 篇文章 1 订阅
140 篇文章 0 订阅

1127. ZigZagging on a Tree (30)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
这里写图片描述
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>
#include <queue>
#include <vector>

using namespace std;
typedef struct tnode
{
    int data;
    struct tnode *lchild;
    struct tnode *rchild;
}TNode,* PTNode;

const int MaxN = 60;
int in[MaxN], post[MaxN];

PTNode CreateTree(int il, int ir, int pl, int pr) {
    if (pl > pr)return nullptr;
    PTNode root = new TNode;
    root->data = post[pr];

    int idx = il;
    while (in[idx] != post[pr])++idx;
    root->lchild = CreateTree(il, idx - 1, pl, pl + idx - il - 1);
    root->rchild = CreateTree(idx + 1, ir, pl + idx - il, pr - 1);

    return root;
}

void zigzag(PTNode root) {
    if (!root) return;
    cout << root->data;
    queue<PTNode> que, backque; bool flag = true;
    if (root->lchild) que.push(root->lchild);
    if (root->rchild) que.push(root->rchild);
    while (que.size()) {
        vector<int>data;
        while (que.size()) {
            PTNode node = que.front(); que.pop();
            if (node->lchild) backque.push(node->lchild);
            if (node->rchild) backque.push(node->rchild);
            data.push_back(node->data); delete node;
        }
        swap(que, backque);

        if (flag) {
            for (int i = 0; i < data.size(); ++i)cout << " " << data[i];
            flag = false;
        }
        else {
            for (int i = data.size()-1; i >=0; --i)cout << " " << data[i];
            flag = true;
        }
    }

    delete root;
}


int main() {
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int n; cin >> n;
    for (int i = 0; i < n; ++i)cin >> in[i];
    for (int i = 0; i < n; ++i)cin >> post[i];

    PTNode root = CreateTree(0, n - 1, 0, n - 1);
    zigzag(root);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值