HDU 1498 50 years, 50 colors (二分图)

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it’s so nice, isn’t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named “crashing color balloons”.

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts “go!”,you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What’s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print “-1”.
Sample Input
1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0
Sample Output
-1
1
2
1 2 3 4 5
-1

题意:给你一个 n*n 的矩阵,每个格子上对应着相应颜色的气球,每次你可以选择一行或一列的同种颜色的气球进行踩破,问你在K次这样的操作后,哪些颜色的气球是不可能被踩破完的。
题解: 二分图的方法,纵横坐标变成可以构成二分图,转换一下思想其实就是让我们求最大匹配数,自己去画一个二分图,大致就能理解每一条匹配边的存在就会有一个匹配点(有着最多的未匹配边)代表着选择的一行或一列被选中去踩破该种颜色的气球

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 110
int n, k, map[M][M], mark[M];
bool vis[M], used[M];

bool bfs(int i, int color)
{
    for(int j=1; j<=n; j++)
    {
        if(map[i][j] == color && !used[j])
        {
            used[j] = true;
            if(mark[j] == -1 || bfs(mark[j], color))
            {
                mark[j] = i;
                return true;
            }
        }
    }
    return false;
}

int getnum(int color)
{
    int sum = 0;
    memset(mark, -1, sizeof(mark));
    for(int i=1; i<=n; i++)
    {
        memset(used, false, sizeof(used));
        if(bfs(i, color))
            sum++;
    }
    return sum;
}
int main()
{
    int m;
    while(scanf("%d%d", &n, &m) && n || m)
    {
        memset(vis, false, sizeof(vis));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d", &map[i][j]);
                if(!vis[map[i][j]])
                    vis[map[i][j]] = true;
            }
        }
        int t = 0, ans[M];
        for(int i=1; i<=50; i++)
        {
            if(vis[i])
            {
                if(getnum(i) > m)
                {
                    ans[t++] = i;
                }
            }
        }
        if(!t)
        {
            printf("-1\n");
            continue;
        }
        for(int i=0; i<t; i++)
        {
            printf("%d", ans[i]);
            if(i == t-1)
                printf("\n");
            else
                printf(" ");
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值