50 years, 50 colors (二分图的最小点覆盖)

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.



Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
Sample Input
1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0
Sample Output
-1
1
2
1 2 3 4 5
-1
题意:
给你一个n*n的格子矩阵每个格子中都存放着一种颜色的气球,现在你有k次机会,每次选择一中颜色,然后在选择一行,或者一列,将这行或这列的这种颜色
的气球全部踩破,k次操作之后将没有踩破的气球安照从小到大的顺序输出,如果没有就输出-1

初次思路:将颜色和边转化为二分图,然后进行二分图匹配,求最小覆盖点,也就是最大匹配,每种颜色的最大匹配的边数
假设所有的边选取的k次的边都是行,或者都是列
#include<stdio.h>
#include<string.h>
using namespace std;
const int N = 150;
int vis[N],match[N];
int e[N][N],mark[N];
int n,m;
int Find(int u,int col){
	for(int i=0;i<n;i++){
		if(!vis[i]&&e[u][i]==col){
			vis[i]=1;
			if(match[i]==-1||Find(match[i],col)){
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int MaxMatch(int col){
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i=0;i<n;i++){
		memset(vis,0,sizeof(vis));
		ans+=Find(i,col);
	}
	return ans;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0) break;
		memset(e,0,sizeof(e));
		memset(mark,0,sizeof(mark));
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				scanf("%d",&e[i][j]);
				if(!mark[e[i][j]]){
					mark[e[i][j]]=1;
				}
			}
		}
		int arr[N]={0},cnt=0;
		for(int i=1;i<=50;i++){
			if(mark[i]){
				if(MaxMatch(i)>m){
					arr[cnt++]=i;
				}
			}
		}
		if(cnt==0) printf("-1\n");
		else{
			for(int i=0;i<cnt-1;i++)
			   printf("%d ",arr[i]);
			printf("%d\n",arr[cnt-1]);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值