Can you solve this equation? (二分法)

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3 Accepted Submission(s) : 2
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
  
  
2 100 -4

Sample Output
  
  
1.6152 No solution!

Author
Redow
 
函数fabs的功能是求指定参数的绝对值
1e-8 表示的数据是 1*10的负8次方
fabs(x)>1e-8
表达的意思就是x的绝对值是否大于一个很小数值0.00000001
常常用来表示迭代计算的停止条件
 
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
#define f(x) (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6)

int main(int ac,char *av[])
{

   double n,Y,res,min,max,mid;
   cin>>n;
   while(n--)
   {
      cin>>Y;
      if(f(0.0)>Y||f(100.0)<Y)
      {
          cout<<"No solution!"<<endl;
          continue;
      }
       min=0.0,max=100.0;
       while(max-min>1e-6)
       {
           mid=(min+max)/2.0;
           res=f(mid);
           if(res>Y)
             max=mid-1e-6;
            else
             min=mid+1e-6;
       }
       printf("%.4lf\n",(min+max)/2.0);
   }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值