PAT 1081. Rational Sum (20)

1081. Rational Sum (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24

这道题先用辗转相除法求GCD,然后就可以求出LCM,然后就是要小心一些细节上的判断就好了。代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
long int gcd(long int x,long int y)
{
	while(y)
	{
		long int rem=x%y;
		x=y;
		y=rem;
	}
	return x;
}
long int lcm(long int a,long int b)
{
	return a*b/gcd(a,b);
}
int main(void)
{
	int N;
	cin>>N;
	long int num[100],den[100];
	for(int i=0;i<N;i++)
		scanf("%ld/%ld",&num[i],&den[i]);
	long int resultNum=0,resultDen=1;
	for(int i=0;i<N;i++)
		resultDen=lcm(resultDen,den[i]);
	for(int i=0;i<N;i++)
		resultNum+=resultDen/den[i]*num[i];
	long int first=0;
	bool flag=true;
	if(resultNum<0)
	{
		flag=false;
		resultNum=-resultNum;
	}
	if(resultNum>resultDen)
	{
		first=resultNum/resultDen;
		resultNum%=resultDen;
	}
	if(resultNum==0)
	{
		if(first>0)
			cout<<first;
		else
			cout<<0;
		return 0;
	}
	long int g=gcd(resultNum,resultDen);
	resultNum/=g;
	resultDen/=g;
	if(flag==false)
		cout<<"-";
	if(first!=0)
		cout<<first<<" ";
	cout<<resultNum<<"/"<<resultDen;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值