【九度OJ】题目1144:Freckles 解题报告

91 篇文章 0 订阅
90 篇文章 33 订阅

【九度OJ】题目1144:Freckles 解题报告

标签(空格分隔): 九度OJ


原题地址:http://ac.jobdu.com/problem.php?pid=1144

题目描述:

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.
Consider Dick’s back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

输入:

The first line contains 0 < n <= 100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:

3
1.0 1.0
2.0 2.0
2.0 4.0

样例输出:

3.41

Ways

最小生成树问题。求最小生成树,首先对边进行排序,然后要遍历所有的边,看这个边是否已经添加到了生成树上,如果没有就把这个边加上去,同时生成树的最终的代价要更新。

这里出错的地方是size的问题,注意其他的循环是从0开始的,但是包含size的循环是从0开始的,包括排序,所以不要搞错。

另外就是如何确定边的问题,没必要非要和顶点扯上关系,只要记录是第几个顶点和第几个顶点之间的边即可。

#include<stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define N 101
int Tree[N];

struct Edge {
    int a, b;
    double cost;

    bool operator<(const Edge &A) const {
        return cost < A.cost;
    }
} edge[6000];

struct Point {
    double x, y;

    double getDistance(Point A) {
        double tmp = (x - A.x) * (x - A.x) + (y - A.y) * (y - A.y);
        return sqrt(tmp);
    }
} point[101];

int findRoot(int x) {
    if (Tree[x] == -1) {
        return x;
    } else {
        int temp = findRoot(Tree[x]);
        Tree[x] = temp;
        return temp;
    }
}

int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        for (int i = 1; i <= n; i++) {
            scanf("%lf%lf", &point[i].x,
                  &point[i].y);//double的输入方式是lf
        }
        int size = 0;
        for (int i = 1; i <= n; i++) {
            for (int j = i + 1; j <= n; j++) {
                edge[size].a = i;//注意,记录的是第几条,不是具体的值
                edge[size].b = j;
                edge[size].cost = point[i].getDistance(point[j]);
                size++;
            }
        }
        sort(edge, edge + size);//从0开始,因为size从0开始
        for (int i = 1; i < N; i++) {
            Tree[i] = -1;
        }
        double answer = 0;
        for (int i = 0; i < size; i++) {//从0开始,因为size从0开始
            int aRoot = findRoot(edge[i].a);
            int bRoot = findRoot(edge[i].b);
            if (aRoot != bRoot) {
                Tree[aRoot] = bRoot;
                answer += edge[i].cost;
            }
        }
        printf("%.2lf\n", answer);
    }

    return 0;
}

Date

2017 年 3 月 10 日

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值