Brackets (区间dp)

Brackets

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

题目意思:有多少个括号匹配的

解题思路:区间dp做的第一道题目~~~看了题解了解了下终于终于知道怎么做了区间dp顾名思义就是区间内的动态规划

动态转移方程就是比如

“--------------------------------------------------------”

  1      2      3          4         5       6        7         8         9

现在要看dp[1][9]的值并且满足19匹配即check为true 所以说那么dp[1][9]=dp[2][8]+2;就是说要看比它小的区间的值

接下来就是比较遍历所有dp[1][9]===dp[1][k]+dp[k][9]。。。。。。。找到最大值如此即可

附上区间dp怎么写的模板

For p:=1 to n do // p是区间长度,作为阶段。
for i:=1 to n do // i是穷举的区间的起点
begin
j:=i+p-1; // j是 区间的终点,这样所有的区间就穷举完毕
if j>n then break; // 这个if很关键。
for k:= i to j-1 do // 状态转移,去推出 f[i,j]
f[i , j]= max{f[ i,k]+ f[k+1,j]+ w[i,j] }

end;


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int Inf=0x3f3f3f3f;
char str[105];
int dp[105][105];
bool check(int i,int k)
{
    if( str[i]=='[' && str[k]==']' || str[i]=='(' && str[k]==')' )
        return true;
    return false;
}
int main()
{
	while(scanf("%s",str+1)!=EOF)
	{
		if(strcmp("end",str+1)==0)break;
		int len=strlen(str+1);
		memset(dp,0,sizeof(dp)); //初始状态
	for(int p = 1;p <= len;p ++)//区间长度
        {
            for(int i=1;i<=len;i++)//i是穷举区间的起点
            {
                int during=p+i-1;//这个是区间的终点
                if(during>len)break;
                    if(check(i,during))
                        dp[i][during] = dp[i+1][during-1]+2;
                    for(int k = i;k<=during;k++)
                        dp[i][during]=max(dp[i][during],dp[i][k]+dp[k+1][during]);
                    //    printf("区间%d     起点%d       终点%d          val=%d\n",p,i,during,dp[i][during]);
            }
        }
        printf("%d\n",dp[1][len]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值