Brackets(区间dp)

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]

while the following character sequences are not:
(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1,a2an a 1 , a 2 … a n , your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1,i2,,im i 1 , i 2 , … , i m where 1i1<i2<<imn 1 ≤ i 1 < i 2 < … < i m ≤ n , ai1,ai2aim a i 1 , a i 2 … a i m is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


题意:

给出一个括号序列,问最长合法非连续括号序列的长度。合法括号序列定义如下:

  • 空串
  • 如果s是合法的,那么(s)和[s]也是合法的
  • 如果a,b是合法的,那么ab也是合法的

分析:

定义状态: dp[i][j] d p [ i ] [ j ] i i 个字符到第j个字符的最长合法括号对的个数
对于当前状态有以下转移:

  • 由于 si+1,...,sj s i + 1 , . . . , s j 以及 si,...,sj1 s i , . . . , s j − 1 都是 si,...,sj s i , . . . , s j 的子串,故必有
    dp[i][j]=max(dp[i+1][j],dp[i][j1]) d p [ i ] [ j ] = m a x ( d p [ i + 1 ] [ j ] , d p [ i ] [ j − 1 ] )
  • 如果 s[i] s [ i ] s[j] s [ j ] 匹配,则有
    dp[i][j]=max(dp[i][j],dp[i+1][j1]+1) d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i + 1 ] [ j − 1 ] + 1 )
  • 区间 [i,j] [ i , j ] 可以由区间 [i,k] [ i , k ] 与区间 [k+1,j] [ k + 1 , j ] 合并得到,即
    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]) d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k + 1 ] [ j ] )

由于题目所求为合法括号序列长度,而dp数组记录的是匹配的括号对数量,故,最终答案为 dp[0][strlen(s)1]2 d p [ 0 ] [ s t r l e n ( s ) − 1 ] ∗ 2


代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<stdlib.h>
#include<iostream>
using namespace std;

#define bll long long

const int maxn = 110;
char s[maxn];
int dp[maxn][maxn];

bool check(int i,int j)
{
    if (s[i] == '(' && s[j] == ')') return true;
    if (s[i] == '[' && s[j] == ']') return true;
    return false;
}

int main()
{
    while (scanf("%s",s)!=EOF)
    {
        if (s[0] == 'e') break;  
        int len = strlen(s);      
        memset(dp,0,sizeof(dp));
        for (int l = 1; l < len; l++)
        {
            for (int i = 0; i < len-l; i++)
            {
                int j = i+l;
                dp[i][j] = max(dp[i+1][j],dp[i][j-1]);
                /**[a] || (b)**/
                if (check(i,j))
                    dp[i][j] = max(dp[i][j],dp[i+1][j-1]+1);
                /**ab**/
                for (int k = i+1; k < j; k++)
                    dp[i][j] = max(dp[i][j],dp[i][k]+dp[k+1][j]);
            }
        }
        printf("%d\n",dp[0][len-1]<<1);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值