Brackets【区间DP】

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

 

    题记——今天有大佬AC了个DP区间树问题,我:???啥玩意,于是开始补DP

 

  思路

  题目问你的是最长的符合情况的“()”or“[]”串的长度,一开始推出来的公式WA了一次,那时候没考虑到如果遇上中间有一段被更新且长度已经大于目前更大的节点时的情况,所以样例过了还是WA。

  后来,我想了些东西,就是举了几组自创样例,想了个办法更新子区间反馈,就是子区间更新了,还要反馈到大区间,于是就一一遍历咯,在【i,j】的大区间内去找个间断点k,查一下【i,k】+【k,j】是否会比【i,j】更大一些,于是就可以更新大节点了。

 

状态转移方程

  • 如果i与j符合区间的两个括号,那么dp[i][j]=max(dp[i][j], dp[i+1][j-1]+2)。记住是+2哦,一次增长两个单位长度。

  • 其余的,dp[i][j]=max(dp[i][j], dp[i][k] + dp[k][j]),其中,k为(i, j)内的任一个数。

 

完整代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi 3.141592653589793
#define e 2.718281828459045
using namespace std;
typedef long long ll;
const int maxN=105;
string s;
int dp[maxN][maxN];
bool check(char e1, char e2)
{
    if(e1=='(' && e2==')') return true;
    else if(e1=='[' && e2==']') return true;
    return false;
}
int main()
{
    while(cin>>s)
    {
        if(s=="end") break;
        memset(dp, 0, sizeof(dp));
        int len=(int)s.size();
        for(int i=2; i<=len; i++)
        {
            for(int j=i; j>=1; j--)
            {
                if(check(s[j-1], s[i-1]))
                {
                    dp[j][i]=max(dp[j][i], dp[j+1][i-1]+2);
                }
                for(int k=j+1; k<=i-1; k++)
                {
                    dp[j][i]=max(dp[j][i], dp[j][k] + dp[k][i]);
                }
            }
        }
        printf("%d\n", dp[1][len]);
        cin.get();
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值