1108 Finding Average (20 分)

1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

注意下 1要注意下

代码:

import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Main {
	private static Scanner sc = new Scanner(System.in);
    public static boolean isNumeric(String str){
    	int cnt = 0;
    	for(int i = 0 ; i < str.length(); i++)
    	{
    		if(str.charAt(i) == '.')
    			cnt++;
    	}
    	if(cnt >= 2)
    		return false;
    	
        for(int i = 0 ; i < str.length(); i++)
        {
        	if(i == 0 && str.charAt(i) == '-')
        		continue;
        	if(str.charAt(i) != '.' && (str.charAt(i) > '9' || str.charAt(i) < '0'))
        		return false;
        }
        int ans = 0, flag = 0;
        for(int i = 0 ; i < str.length(); i++)
        {
        	if(str.charAt(i) == '.')
        		flag = 1;
        	if(flag == 1)
        	{
        		if(str.charAt(i) >= '0' && str.charAt(i) <= '9')
        			ans++;
        		if(ans >= 3)
        			return false;
        	}
        }
        
        return true;
    }
	public static void main(String[] args){
		int n = sc.nextInt(), cnt = 0;
		String s;
		double sum = 0;
		for(int i = 0; i < n; i ++)
		{
			s = sc.next();
			if(isNumeric(s) == true) //表明至少是个浮点数字或者整数了
			{
				double gg = Double.parseDouble(s);
				if(gg > 1000.0|| gg < -1000.0)
					System.out.println("ERROR: "+ s +" is not a legal number");
				else 
				{
					cnt ++;
					sum += gg;
				}
			}else
				System.out.println("ERROR: "+ s +" is not a legal number");
		}
		if(cnt == 0)
			System.out.println("The average of 0 numbers is Undefined");
		else if(cnt == 1)
			System.out.printf("The average of 1 number is %.2f\n",sum);
		else
			System.out.printf("The average of %d numbers is %.2f\n",cnt,sum / (cnt * 1.0));		
	}
}

 

Finding bugs(寻找错误)是指在软件开发过程中,为了保证软件的质量和稳定性,通过一系列的测试和调试过程,找出软件中存在的错误和缺陷,并进行修复的活动。 寻找错误是软件开发过程中必不可少的一步。在软件开发过程中,无论是编写代码、设计界面还是实施功能,都可能出现各种各样的错误。这些错误可能导致软件无法正常运行、功能异常或者性能低下。为了及时发现和修复这些错误,需要进行系统而全面的错误寻找工作。 寻找错误的方法和技巧有很多种。其中一种常用的方法是黑盒测试。黑盒测试是指在不了解软件内部结构和具体实现的情况下,通过输入一些指定的测试用例,观察软件的输出结果,并与预期结果进行对比,从而判断软件是否存在错误。另外一种方法是白盒测试。白盒测试是指在了解软件内部结构和具体实现的情况下,通过对代码进行逐行逐句的检查,发现其中潜在的错误。 除了以上的方法,还可以使用自动化的测试工具来辅助寻找错误。这些工具能够模拟用户的操作,快速地执行大量的测试用例,并生成详细的测试报告,帮助开发人员准确定位和修复错误。 在寻找错误的过程中,要保持耐心和专注。有时候错误可能隐藏得很深,需要仔细地析和调试。同时,还要注重记录和总结错误,以便后续的修复工作。 总之,寻找错误是软件开发过程中不可或缺的一环。通过系统而全面的测试和调试工作,可以及时发现和修复软件中存在的错误和缺陷,提高软件的质量和可靠性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值