1138~Trailing Zeroes (III) (二分法的应用)

一道关于二分法 的题

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.


Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.


Output

For each case, print the case number and N. If no solution is found then print 'impossible'


.Sample Input

3

1

2

5


 

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


这是一个求 n的阶乘尾数0的个数的一种方法。详解如下。

https://blog.csdn.net/ee8736199/article/details/48105017


​
#include<stdio.h>
int num(int n) //求n的阶乘末尾连续0的个数 
{              
      
      int ans=0;
      while(n)
      {ans+=n/5;
       n=n/5;    
     }
     return ans;    
}
 int main()
 {
     int mid,i=1;
     int t ,q;
     long long l,r;
     scanf("%d",&t);
     while(t--)
     {scanf("%d",&q);
      l=0;
      r=100000000000000;  //r要大于1e8
      long long m=0;
      while(l<=r)
        {mid=(l+r)/2;
         if(num(mid)==q)
           {r=mid-1;
            m=mid;    
           }
         else 
           {if(num(mid)>q)       //二分法
                r=mid-1;       
            else l=mid+1;      
           }    
        }
       if(m==0) printf("Case %d: impossible\n",i); 
       else printf("Case %d: %lld\n",i,m);
       i++;    
     }
     return 0;
}

​

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值