50 years, 50 colors(二分图)

Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons". 

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons. 

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times. 


 

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0. 
 

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1". 
 

Sample Input

    
    
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output

    
    
-1 1 2 1 2 3 4 5 -1

解题思路

这题其实和前面棋盘游戏那题差不多,要清楚行列是怎么匹配的,按行列,每次选中一未访问的颜色,求最小覆盖数,如果大于k了,肯定是k次踩不完的。


AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int  MAXN = 105;
int map[MAXN][MAXN];
int match[MAXN], vis[MAXN], used[MAXN], ans[MAXN];
int n, k;

bool cmp(int a, int b)
{
    return a < b;
}

int find(int i, int color)
{
    for(int j = 1; j <= n; j++)
    {
        if(map[i][j] == color && !vis[j])
        {
            vis[j] = 1;
            if(match[j] == -1 || find(match[j], color))
            {
                match[j] = i;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i, j, t, w, sum, len;
    while(scanf("%d%d", &n, &k))
    {
        if(n == 0 && k == 0)
            break;
        memset(map, 0, sizeof(map));
        memset(used, 0, sizeof(used));
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                scanf("%d", &map[i][j]);
        len = 0;
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                memset(match, -1, sizeof(match));
                sum = 0;
                if(!used[ map[i][j] ])
                {
                    used[ map[i][j] ] = 1;
                    for(t = 1; t <= n; t++)
                    {
                        memset(vis, 0, sizeof(vis));
                        sum += find(t, map[i][j]);
                    }
                }
                if(sum > k)
                    ans[len++] = map[i][j];
            }
        }
        if(len == 0)
            printf("-1\n");
        else
        {
            sort(ans, ans + len, cmp);
            for(i = 0; i < len; i++)
            {
                if(i)
                    printf(" ");
                printf("%d", ans[i]);
            }
            printf("\n");
        }

    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值