#1108. Finding Average【模拟 + 字符串处理】

该博客主要介绍了一种处理包含非法输入(如超出范围或精度错误的数字)的算法,用于计算一组实数的平均值。通过使用C++编程,博主展示了如何使用<stringstream>库来分割输入字符串,检查每个数字的合法性,包括范围和精度,并排除非法数字,最后计算合法数字的平均值。示例展示了对于非法输入如何输出错误信息,并在所有输入均为非法时,正确输出平均值为'Undefined'的情况。
摘要由CSDN通过智能技术生成

原题链接

Problem Description:

The basic task is simple: given N N N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [ − 1000 , 1000 ] [−1000,1000] [1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N ( ≤ 100 ) \leq 100) 100). Then N N N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

Problem Analysis:

利用 <sstream> 下的 stringstream 流对输入的一整行字符串进行切割,分别处理每个单词,判断是否合法。

具体细节见代码注释。

Code

#include <iostream>
#include <algorithm>
#include <cstring>
#include <sstream>

using namespace std;

bool check(char c)
{
    if (c <= '9' && c >= '0') return true;
    if (c == '.' || c == '-') return true;
    return false;
}

int main()
{
    int n;
    cin >> n;
    getchar();
    string str;
    getline(cin, str);

    string word;
    stringstream ss(str);

    double ans = 0; // 合法数字之和
    int cnt = 0; // 合法数字个数

    while (ss >> word) // 切割字符串,分别处理每个单词
    {
        bool success = true, point = false; // point 为小数点标志位
        int d = 0; // 小数点后精确位数
        for (int i = 0; i < word.size(); i ++ )
            if (check(word[i]))
            {
                if (!point && word[i] == '.') point = true; // 如果之前没有出现过小数点,标志位置为 true
                else if (word[i] == '.' && point) // 第二次出现小数点,不合法
                {
                    success = false;
                    break;
                }
                if (point && (word[i] >= '0' && word[i] <= '9')) ++ d; // 之前出现过小数点,并且这位是数字,精确位数 ++
            }
            else 
            {
                success = false;
                break;
            }
        if (d > 2) success = false; // 如果精确位数不止2位,不合法

        if (word.size() == 1 && (word[0] == '.' || word[0] == '-')) success = false; // 特判:如果单词只有一个 - 或 . 也是不合法的

        if (success && (stod(word) < -1000 || stod(word) > 1000)) success = false; // 超出范围,不合法

        if (!success) printf("ERROR: %s is not a legal number\n", word.c_str()); // 输出
        else 
        {
            cnt ++ ; // 累计计数
            ans += stod(word);
        }
    }

    if (cnt == 1) printf("The average of %d number is %.2f\n", cnt, ans / cnt);
    else if (cnt > 1) printf("The average of %d numbers is %.2f\n", cnt, ans / cnt);
    else puts("The average of 0 numbers is Undefined");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值