B - Factors of Factorial AtCoder - 2286

You are given an integer N. Find the number of the positive divisors of N!, modulo 109+7.


Constraints
  • 1N103
Input

The input is given from Standard Input in the following format:

N
Output

Print the number of the positive divisors of N!, modulo 109+7.

Sample Input 1
3
Sample Output 1
4

There are four divisors of 3! =6: 1, 2, 3 and 6. Thus, the output should be 4.

题意:求n的阶乘的因子数;

思路:数论的原理,n的阶乘的因子个数等于n的素因子个数的幂的乘积;

下面附上我的代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int k[1005]; 
const LL mod=1e9+7;
int main()
{
	int n;
	cin>>n;
	for(int i=2;i<=n;i++)
	{
		int l=i;
		for(int j=2;j<=l;j++)
		{
			while(l%j==0)
			{
				k[j]++;
				l/=j;
			}	
		}
		if(l) k[l]++;
	}
	LL sum=1;
	for(int i=2;i<=n;i++)
	{
		if(k[i])
		{
			sum*=(k[i]+1);
			sum=sum%mod;
		}
	}					
	printf("%lld\n",sum%mod);
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值