HDU 5974

A Simple Math Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1784 Accepted Submission(s): 522


Problem Description


Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b



Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.


Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).


Sample Input

6 8
798 10780



Sample Output

No Solution
308 490


题意:输入两个数a, b;问是否存在X , Y使得条件X + Y = a, 且 lcm(X, Y) = b满足.(这里的的lcm(X, Y) = b,是X, Y的最小公倍数是b的简单表达)

这一题需要用到一个结论, 就是 gcd(X, Y) = gcd(a, b);(这里的gcd(a, b)是a, b最大公约数的记号);

这个结论是如何得到的呢?请看紫书数论部分,有解释。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b){
    return !b ? a : gcd(b, a%b);
}
int main(){
    ll a,b;
    while (~scanf("%lld %lld",&a, &b))
    {
        int g = gcd(a,b);
        ll B = b * g;
        ll q = a*a - 4 * B;
        if (q < 0) 
        {
            puts("No Solution");
            continue;
        }
        bool ok = 1;
        ll tmp = sqrt(q);
        if (tmp * tmp != q) 
            ok = 0;
        ll a1 = (a + tmp);
        ll a2 = (a - tmp);
        if (a1 & 1 || a2 & 1) ok = 0;
        ll ans1 = min(a1,a2);
        ll ans2 = max(a1,a2);
        if (ok)printf("%lld %lld\n",ans1/2,ans2/2);
        else puts("No Solution");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值