Binary Numbers

Binary Numbers

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example
 
The positions of 1's in the binary representation of 13 are 0, 2, 3.
 
Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,
 
writes the result.

输入

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

输出

The output should consists of exactly d lines, one line for each data set.
 
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

示例输入

1
13

示例输出

0 2 3

提示


来源

面向对数据结构和算法不太懂的同学

示例程序

 
#include<stdio.h>  
int main()  
{  
int i,j,n,m,k,t,a[100];  
scanf("%d",&t);  
while(t--)  
{  
scanf("%d",&n);  
i=0;  
while(n>0)  
{  
a[i++]=n%2;  
n=n/2;  
}  
k=0;  
for(j=0;j<i;j++)  
{  
//printf("%d",k);  
if(k==0&&a[j]==1)  
printf("%d",j);  
if(k!=0&&a[j]==1)  
printf(" %d",j);  
k++;  
}  
printf("\n");  
}  
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值