Binary Numbers
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.
Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the positions of 1's in the binary representation of n,
writes the result.
Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the positions of 1's in the binary representation of n,
writes the result.
输入
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
输出
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
示例输入
1 13
示例输出
0 2 3
提示
来源
面向对数据结构和算法不太懂的同学
示例程序
#include<stdio.h>
int main()
{
int i,j,n,m,k,t,a[100];
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
i=0;
while(n>0)
{
a[i++]=n%2;
n=n/2;
}
k=0;
for(j=0;j<i;j++)
{
//printf("%d",k);
if(k==0&&a[j]==1)
printf("%d",j);
if(k!=0&&a[j]==1)
printf(" %d",j);
k++;
}
printf("\n");
}
}