1013 Battle Over Cities (25 分)

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​​-city​2 and city1​​ -city3​​ . Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​ -city​3.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0

题目大意:
给定n个城市,m条路,问删除一个结点及它所连接的路时,剩余城市间需要加几条路才能形成连通图

算法分析:
添加最少的路的条数实际上就是他们的连通分量个数-1,因为n个连通分量最少用n-1条边才能形成一个连通图。这里用DFS求连通分量的个数,一次DFS就能遍历完所有结点的,连通分量的个数为1

AC代码:

#include<bits/stdc++.h>
using namespace std;
bool visit[1010];
vector<int> v[1010];//存储图信息 
int n,m,k,except;
void DFS(int index){
	visit[index]=true;
	if(index!=except){
	for(int i=0;i<v[index].size();i++){
		if(visit[v[index][i]]==false)DFS(v[index][i]);
	}
	}
}
int main(){
	cin>>n>>m>>k;
	int a,b;
	for(int i=0;i<m;i++){
		cin>>a>>b;
		v[a].push_back(b);
		v[b].push_back(a);//无向图存储 
	}
	for(int i=0;i<k;i++){
		cin>>except;
		fill(visit,visit+1010,false);//注意每次更新visit数组 
		int cnt=0;
		for(int j=1;j<=n;j++){
			if(visit[j]==false&&j!=except){
				DFS(j);
				cnt++;
			}
		}//计算连通分量的个数,一次DFS就遍历完所有结点就只有一个连通分量 
		printf("%d\n",cnt-1);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值