In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.
Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.
Input
The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.
Output
For each test case, output the average rounded to six digits after decimal point in a separate line.
Sample Input
1 2 5 1 2 3 4 5 4 2 10 2121187 902 485 531 843 582 652 926 220 155 0 0 0
Sample Output
3.500000 562.500000
Hint
This problem has very large input data. scanf and printf are recommended for C++ I/O.
The memory limit might not allow you to store everything in the memory.
题解:构建两个you优先队列,一个大顶堆,一个小顶堆,分别储存需要去掉的最高分和最低分,最后从总和中减去队列中的元素,求平均值即可;
代码:
#include <iostream>
#include <string>
#include <cstring>
#include <map>
#include <string.h>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include<queue>
#include<vector>
using namespace std;
int main()
{
int n1,n2,n,a,len1,len2;
double s;
while(cin>>n1>>n2>>n && (n1 || n2 || n))
{
long long sum=0;
priority_queue<int,vector<int>,greater<int> > pq1;//小顶堆;用来储存 n1 个最大值;
priority_queue<int,vector<int>,less<int> >pq2;//大顶堆;用来储存 n2 个最小值;
for(int i=0; i<n; i++)
{
scanf("%d",&a);
sum+=a;
pq1.push(a);
len1=pq1.size();
if(len1>n1)
{
pq1.pop();
}
pq2.push(a);
len2=pq2.size();
if(len2>n2)
{
pq2.pop();
}
}
while(!pq1.empty())
{
sum-=pq1.top();
pq1.pop();
}
while(!pq2.empty())
{
sum-=pq2.top();
pq2.pop();
}
s=sum*1.0/(n-n1-n2);
printf("%.6lf\n",s);
}
return 0;
}