最大乘积(Maximum Product,UVa11059)

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.

Case #2: The maximum product is 20.


   连续子序列有两个元素:起点和终点,因此只需枚举起点和终点即可。注意用long long存储


第一次做的时候,测试都对提交却是WA,真不知道哪里错了。有哪位游客知道的,麻烦留言谢谢~

//哪里有错误? 
#include<stdio.h>
#include<string.h>
int a[20];
long long ans;
int cmp(int b,int c)
{
	long long sum=1;
	for(int i=b;i<=c;i++)
	{
		sum*=a[i];
	}
	return sum;
}
int main()
{
	int n,i,j,kase=1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		//找出这串数字中最大值。 
		for(i=0,ans=0;i<n;i++) 
		{
			scanf("%d",&a[i]);
			if(ans<a[i])
			ans=a[i];
	    }
		for(i=0;i<n;i++)//i,j分别表示起始点坐标 
		{
			for(j=i+1;j<n;j++)
			{
				if(ans<cmp(i,j))
				ans=cmp(i,j);
			}
		}
		printf("Case #%d: The maximum product is %lld.\n\n",kase++,ans);
	}
} 


 参考网上他人AC的代码,也是比较好理解: 

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int kase=1,n,a[20];
	while(scanf("%d",&n)!=EOF)
	{
		long long ans=0;
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		for(int i=1;i<=n;i++) //i表示序列长度 
		{
			for(int j=0;j+i<=n;j++) //j表示首元素下标 
			{
				long long t=1;
				for(int k=j;k<j+i;k++)
				{
					t*=a[k];
				}
				ans=max(ans,t);
			}
		}
		printf("Case #%d: The maximum product is %lld.\n\n",kase++,ans);
	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值