PAT甲级 -- 1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000]which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

我的思路:

1. 建立结构体,进行建树。

2.用深搜将每一层的key值放入 lay{}index] ,最后输出最后两层的个数即可!等我下课回来写! 

补代码:28分,两个点段错误!!

修正: lay数组应该开到1000!二叉搜索树有可能只要一只,所以深度有可能会是1000喔!!!!(刚开始还考虑不会那么极端~)

#include <iostream>
#include <vector>
#include <cmath>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;

struct node
{
	int key;
	node* lchild, *rchild;
};

vector<int> lay[1000];  //这个地方要开到1000!!!

int n, maxIndex = 0;

node* build(node* root, int v){
	if(root == NULL){
		root = new node();
		root->key = v;
		root->lchild = root->rchild = NULL;
	}else if(v <= root->key){
		root->lchild = build(root->lchild, v);
	}else 
		root->rchild = build(root->rchild, v);
	return root;
}

void dfs(node* root, int index){

	if (root == NULL) return;

	if(maxIndex < index){
		maxIndex = index;
	}

	lay[index].push_back(root->key);
	if(root->lchild) dfs(root->lchild, index+1);
	if(root->rchild) dfs(root->rchild, index+1);
}

int main(){
	scanf("%d", &n);
	node* root = NULL;
	int t;
	for(int i = 0; i < n; i++){
		scanf("%d", &t);
		root = build(root, t);
	}
	dfs(root,0);
	printf("%d + %d = %d\n", lay[maxIndex].size(), lay[maxIndex-1].size(), lay[maxIndex].size()+lay[maxIndex-1].size());
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值