PAT甲级 -- 1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2Nlines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

我的思路:25分

1. 给定的push顺序为前序遍历的顺序,pop的顺序是中序遍历的顺序,得到两个,得到后序岂不容易?

2. 先读入操作(push or pop),然后再进行下一步处理。

#include <iostream>
#include <vector>
#include <stack>
#include <string>
using namespace std;
int n;
stack<int> s;
vector<int> inorder,preOrder,postOrder;
void post(int inl, int inr, int preRoot){
	if(inl > inr) return;
	int i = inl;
	while(i < inr && inorder[i] != preOrder[preRoot]) i++;
	post(inl, i-1, preRoot+1);
	post(i+1, inr, preRoot+1+(i-inl));
	postOrder.push_back(preOrder[preRoot]);
}
int main(){
	scanf("%d", &n);
	for(int i = 0; i < 2 * n; i++){
		string str;
		cin >> str;
		if(str == "Push"){
			int num;
			scanf("%d", &num);
			s.push(num);
			preOrder.push_back(num);
		}else if(str == "Pop"){
			inorder.push_back(s.top());
			s.pop();
		}
	}
	post(0, n-1, 0);
	printf("%d", postOrder[0]);
	for(int i = 1; i < postOrder.size(); i++){
		printf(" %d", postOrder[i]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值