CF1515C Phoenix and Towers

Phoenix and Towers

题目描述

Phoenix has $ n $ blocks of height $ h_1, h_2, \dots, h_n $ , and all $ h_i $ don’t exceed some value $ x $ . He plans to stack all $ n $ blocks into $ m $ separate towers. The height of a tower is simply the sum of the heights of its blocks. For the towers to look beautiful, no two towers may have a height difference of strictly more than $ x $ .

Please help Phoenix build $ m $ towers that look beautiful. Each tower must have at least one block and all blocks must be used.

输入格式

The input consists of multiple test cases. The first line contains an integer $ t $ ( $ 1 \le t \le 1000 $ ) — the number of test cases.

The first line of each test case contains three integers $ n $ , $ m $ , and $ x $ ( $ 1 \le m \le n \le 10^5 $ ; $ 1 \le x \le 10^4 $ ) — the number of blocks, the number of towers to build, and the maximum acceptable height difference of any two towers, respectively.

The second line of each test case contains $ n $ space-separated integers ( $ 1 \le h_i \le x $ ) — the heights of the blocks.

It is guaranteed that the sum of $ n $ over all the test cases will not exceed $ 10^5 $ .

输出格式

For each test case, if Phoenix cannot build $ m $ towers that look beautiful, print NO. Otherwise, print YES, followed by $ n $ integers $ y_1, y_2, \dots, y_n $ , where $ y_i $ ( $ 1 \le y_i \le m $ ) is the index of the tower that the $ i $ -th block is placed in.

If there are multiple solutions, print any of them.

样例 #1

样例输入 #1

2
5 2 3
1 2 3 1 2
4 3 3
1 1 2 3

样例输出 #1

YES
1 1 1 2 2
YES
1 2 2 3

提示

In the first test case, the first tower has height $ 1+2+3=6 $ and the second tower has height $ 1+2=3 $ . Their difference is $ 6-3=3 $ which doesn’t exceed $ x=3 $ , so the towers are beautiful.

In the second test case, the first tower has height $ 1 $ , the second tower has height $ 1+2=3 $ , and the third tower has height $ 3 $ . The maximum height difference of any two towers is $ 3-1=2 $ which doesn’t exceed $ x=3 $ , so the towers are beautiful.

大意就是给定 n块积木,每块积木都有一个小于 x 的高度,要将这 n 块积木分成 m 堆非空的集合,且满足任意两集合的高度和的差都不大于 x,求任意一种构造方案。
每块高度都小于x,所以每次把该块放到高度最低的塔上就行。

#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int manx = 2e5 + 10;
int a[manx];
typedef pair<int, int >PII;
priority_queue<PII, vector<PII>, greater<PII>>q;//使用优先队列,把每次高度最小的塔放在队首。
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		while (!q.empty())
		{
			q.pop();
		}
		int n, m, x;
		cin >> n >> m >> x;
		for (int i = 1; i <= m; i++)
		{
			q.push({ 0,i });//每个塔初始高度都为0;
		}
		cout << "YES" << endl;
		for (int i = 1; i <= n; i++)
		{
			int cnt;
			cin >> cnt;
			int h = q.top().first, r = q.top().second;
			cout << r << " ";
			q.pop();//弹出即将要修改高度的塔。
			q.push({ h + cnt,r });
		}

		cout << endl;
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值