poj 2282 The Counting Problem (数位DP)

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Source


题意:求出区间内0~9的个数

思路:建立f(k)和f(10*k+x)的关系,也就是说对于一个大数,先处理到末尾为0,然后再认为是从0开始10个10个数数到这个数。例如,f(2984)就先从2981数到2984(2,9,8各出现4次,1,2,3,4一次)然后f(2980)可以和f(298)建立递推(实际的时候用f(297)更好一点)。注意这里需要建立一个“乘子”,一开始为1,每次递推一层就*10,然后累加到0-9的记录上。

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int a[10],b[10];
void dfs(int n,int ans[],int len)
{
    if(n<=0)
       return;
    int d=n%10;
    int p=n/10;
    for(int i=1;i<=d;i++)  //不从0开始是方便下面第二个for循环;
        ans[i]+=len;
    while(p>0)
    {
        ans[p%10]+=(d+1)*len;  //尾数 0到d 对应有多少高位
        p=p/10;
    }
    for(int i=0;i<=9;i++)  
       ans[i]+=(n/10)*len;
    dfs(n/10-1,ans,len*10);
}
int main()
{
    int x,y;
    while(scanf("%d%d",&x,&y),x+y>0)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        if(x>y)
            swap(x,y);
        x--;
        if(x<y)
        {
            dfs(y,b,1);
            dfs(x,a,1);
        }
        for(int i=0;i<=9;i++)
        {
            if(i==9)
                printf("%d\n",b[i]-a[i]);
            else
                printf("%d ",b[i]-a[i]);
        }
    }
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值