HDU 1402 A * B Problem Plus

A * B Problem Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11884    Accepted Submission(s): 2052


Problem Description
Calculate A * B.
 

Input
Each line will contain two integers A and B. Process to end of file.

Note: the length of each integer will not exceed 50000.
 

Output
For each case, output A * B in one line.
 

Sample Input
  
  
1 2 1000 2
 

Sample Output
  
  
2 2000
 

Author
DOOM III
大数相乘的  FFT模板,来自kuangbin大神



  
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define PI acos(-1.0)
using namespace std;
struct complex
{
	double r,i;
	complex (double _r=0.0,double _i=0.0)
	{
		r=_r;i=_i;
	}
	complex operator +(const complex &b)
	{
		return complex(r+b.r,i+b.i);
	}
	complex operator -(const complex &b)
	{
		return complex(r-b.r,i-b.i);
	}
	complex operator *(const complex &b)
	{
		return complex(r*b.r-i*b.i,r*b.i+i*b.r);
	}
};
void change(complex y[],int len)
{
	int i,j,k;
	for(i=1,j=len/2;i<len-1;i++)
	{
		if(i<j)
			swap(y[i],y[j]);
		k=len/2;
		while(j>=k)
		{
			j-=k;
			k/=2;
		}
		if(j<k)
			j+=k;
	}
}
void fft(complex y[],int len,int on)
{
	change(y,len);
	for(int h=2;h<=len;h<<=1)
	{
		complex wn(cos(-on*2*PI/h),sin(-on*2*PI/h));
		for(int j=0;j<len;j+=h)
		{
			complex w(1,0);
			for(int k=j;k<j+h/2;k++)
			{
				complex u=y[k];
				complex t=w*y[k+h/2];
				y[k]=u+t;
				y[k+h/2]=u-t;
				w=w*wn;
			}
		}
	}
	if(on==-1)
		for(int i=0;i<len;i++)
			y[i].r/=len;
}
const int Maxn=200010;
complex x1[Maxn],x2[Maxn];
char str1[Maxn/2],str2[Maxn/2];
int sum[Maxn];
int main()
{
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	while(~scanf("%s%s",str1,str2))
	{
		int len1=strlen(str1);
		int len2=strlen(str2);
		int len=1;
		while(len<len1*2||len<len2*2)
			len<<=1;
		for(int i=0;i<len1;i++)
			x1[i]=complex(str1[len1-i-1]-'0',0);
		for(int i=len1;i<len;i++)
			x1[i]=complex(0,0);
		for(int i=0;i<len2;i++)
			x2[i]=complex(str2[len2-i-1]-'0',0);
		for(int i=len2;i<len;i++)
			x2[i]=complex(0,0);
		fft(x1,len,1);
		fft(x2,len,1);
		for(int i=0;i<len;i++)
			x1[i]=x1[i]*x2[i];
		fft(x1,len,-1);
		for(int i=0;i<len;i++)
			sum[i]=int(x1[i].r+0.5);
		for(int i=0;i<len;i++)
		{
			sum[i+1]+=sum[i]/10;
			sum[i]%=10;
		}
		len=len1+len2-1;
		while(sum[len]<=0&&len>0)
			len--;
		for(int i=len;i>=0;i--)
			printf("%c",sum[i]+'0');
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值