POJ 2386 Lake Counting(简单dfs)

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26942 Accepted: 13532

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.  

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M  

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3


  这个题目是简单的深度搜索题目,题意:连天下雨,农夫的n*m田地里有积水,积水连成了小水洼,让你计算小水洼有几个。

  易知,这个题目的做法是dfs,因为其“从某一个状态转移到另一个状态,直到其无法转移为止,且无固定初末状态”。

代码如下:

#include<iostream>
using namespace std;
int n,m;
char str[105][105];
void solve();
void dfs(int ,int );
int main()
{
    cin>>n>>m;//n行m列
    for(int i=0;i<n;i++)
        cin>>str[i];
    solve();
    return 0;
}
void solve()
{
    int res=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            if(str[i][j]=='W')
            {
                dfs(i,j);
                res++;
            }
            cout<<res<<endl;
}
void dfs(int x,int y)
{
    int nx,ny;
    str[x][y]='.';//走过的水坑更新为陆地
    //遍历上下左右八个方向
    for(int fx=-1;fx<=1;fx++)
        for(int fy=-1;fy<=1;fy++)
        {
            nx=x+fx,ny=y+fy;
            //判断遍历的点是否在n*m的地盘内以及是否是水坑
            if(nx>=0&&nx<n&&ny>=0&&ny<m&&str[nx][ny]=='W')
                dfs(nx,ny);
        }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值