GitHub 弃用TLS 1.0、1.1导致SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

报错

git push 到 Github 的时候出现异常:

fatal: unable to access 'https://github.com/huihut/interview.git/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
Pushing to https://github.com/huihut/interview.git

原因

在 2018年2月22日19:00 UTC(太平洋标准时间上午11:00),GitHub 停止了对加密弱 TLS 1.0 和 1.1 协议的支持,并且仅支持与 TLS 1.2 协议的连接。

官方声明:

Github . Weak cryptographic standards removal notice

因此,如果你的 git 连接方式仍然是 TLS 1.0 或 1.1,则会报错。

解决

① 查看你的 TLS 版本

git config --global --list

② 如果仍然是 TLS 1.0 或 1.1,则下载更新 Git 最新版:https://git-scm.com/

③ 安装好最新版 Git 后,更新 TLS

git config --global --unset http.sslVersion
git config --global --add http.sslVersion tlsv1.2

④ 现在则可以使用 TLS 1.2 传输,并解决了此问题

操作如下图:

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 2

打赏作者

辉哈

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值