hdu acm 1498 50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2024    Accepted Submission(s): 1114


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
  
  
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
  
  
-1 1 2 1 2 3 4 5 -1
解题关键:把矩阵中每种颜色分成一组,x坐标和y坐标分成2个集合,每组内x坐标和y坐标连成一条边。若最小覆盖点>k,则输出该种颜色。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#include<map>
#define maxn 2000
#define MS(a,b) memset(a,b,sizeof(a));
int n,m,head[maxn],vis[maxn],f;
int link[maxn];
struct node
{
    int e,next;
}edge[500005];
void add(int s,int e)
{
    edge[f].e=e;
    edge[f].next=head[s];
    head[s]=f++;
}
bool dfs(int u)
{
    int i,v;
    for(i=head[u];i!=-1;i=edge[i].next)
    {
       v=edge[i].e;
       if(!vis[v])
       {
           vis[v]=1;
           if(link[v]==-1||dfs(link[v]))
           {

               link[v]=u;
               return true;
           }
       }
    }
     return false;
}
int main()
{
     int n,k,i,mat[300][300],j,ans,sign,a[200];
     int color,h;
     while(cin>>n>>h)
     {
         if(n==0&&h==0)break;
         for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
              cin>>mat[i][j];
              sign=1;
              int g=0;
          for(color=1;color<=50;color++)
            {   f=1;
               MS(head,-1);
                for(i=1;i<=n;i++)
                  for(j=1;j<=n;j++)
                {
                  if(mat[i][j]==color)
                    add(i,j);
                }
                MS(link,-1);
                ans=0;
                for(k=1;k<=n;k++)
                {
                  MS(vis,0);
                  if(dfs(k))
                    ans++;
                }
                if(ans>h)
                {
                     a[g++]=color;
                     sign=0;
                }
            }
           if(sign)
              cout<<"-1";
              else
              {
                 for(i=0;i<g-1;i++)
                    cout<<a[i]<<" ";
                   cout<<a[i];
              }
           cout<<endl;
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值