POJ2492 A Bug's Life

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 36242 Accepted: 11853

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany



#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int par[2005],rank[2005],flag;

int find(int x){
	if(x != par[x]){
		int t = par[x];
		par[x] = find(par[x]);
		rank[x] = (rank[x] + rank[t]) % 2;//表示当前节点与其父节点的关系,实际上就是间接与根结点的关系 
	}
	return par[x];
}

void UnionSet(int u, int v){
	int x = find(u);
	int y = find(v);
	
	if(x == y){
		if(rank[u] == rank[v]){//有相同的父节点且和父节点的关系相同,则证明是同性恋 
			flag = 1;
			return ;
		}
	}
	par[x] = y;
	rank[x] = (rank[u] + rank[v] + 1) % 2;//u和v的根结点不是同一个,合并两个节点的根结点, 
}//u和v是异性,当u和v连接起来,则又多了一条边,所以要加1 

int main(){
	int t,n,m,cas = 0;
	scanf("%d",&t);
	while(t --){
		flag = 0;
		scanf("%d%d",&n,&m);
		int u,v;
		for(int i = 1; i <= n; i ++){
			par[i] = i;
			rank[i] = 0;//用rank来记录第i个节点与其父节点的关系, 
		}
		for(int i = 1; i <= m; i ++){
			scanf("%d%d",&u,&v);
			UnionSet(u,v);
		}
		printf("Scenario #%d:\n",++cas);
		if(flag)
			printf("Suspicious bugs found!\n");
		else
			printf("No suspicious bugs found!\n");
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值