TZOJ 5103 Electric Fence 皮克

描述:

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入:

The single input line contains three space-separated integers that denote n, m, and p.

输出:

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入:

7 5 10
样例输出:

20

题目意思就是给定一个三个顶点都在顶点的三角形,要求你求出三角形内的格点数;

这玩意一开始看还怪让人感觉蒙圈的,毕竟一个三角形要数格点只能找规律,而规律有时候又不是光列举才能想到的;

不过看了题目分析便懂了;

本题需要用到皮克定理:

皮克定理是指一个计算点阵中顶点在格点上的多边的面积公式。

s=a+\frac{b}{2}-1;

其中a表示多边形内部的点数,b表示多边形落在格点边界上的点数,S表示多边形的面积。

于是乎我们求的a则为

a=s+1-\frac{b}{2}

三角形面积s好求

s=底*高/2;

而格点边界上的点又要怎么求呢?

我们作了以下的图

最后不难得出

在格上的点的数量b=gcd ( n,m)+gcd(abs(p-n),m)+p

于是答案便呼之欲出了

#include<bits/stdc++.h>
using namespace std;
int gcd(int a,int b)
{
	while(b!=0)
	{
		int m=a%b;
		a=b;
		b=m;
	}
	return a;
}
int main()
{
	int n,m,p,s,ds;
	cin>>n>>m>>p;
	s=p*m/2;
	ds=gcd(abs(n-p),m)+gcd(n,m)+p;
	cout<<s-ds/2+1<<endl;
 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值