TZOJ5103: Electric Fence(皮克定理)

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

题意:

在这个问题中,平面中的“格点”是具有整数坐标的点。

为了容纳他的奶牛,农夫约翰建造了一个三角形的电栅栏,将一根“热”线从原点(0,0)串到晶格点[n,m](0<=n<32,000,0<m<32,000),然后到正x轴[p,0](0<p<32,000)上的晶格点,然后回到原点(0,0)。

可以在围栏内的每个格子点放置一头牛,而无需接触围栏(非常薄的奶牛)。奶牛不能放在栅栏接触的格子点上。一个给定的围栏可以容纳多少头奶牛?

输入

单个输入行包含三个空格分隔的整数,分别表示 n、m 和 p。

输出

带有单个整数的单行,表示指定的围栏可以容纳的奶牛数量。

样例输入

7 5 10

样例输出

20

题目也就是求出三角形内的格点数。这里就引出了皮克定理。
皮克定理是指一个计算点阵中顶点在格点上的多边形面积公式,该公式可以表示为S = a+b/2-1,其中a表示多边形内部的点数,b表示多边形落在格点边界上的点数,S表示多边形的面积。

本题就是求出a的值,S我们可以用三角形的底乘高公式S = m * p / 2;那么我们只要求出b即可。一条直线((x1,y1),(x2,y2))上的格点数等于abs(x2-x1)与abs(y2-y1)的最大公约数+1,所以一条线段的格点数(包括端点)= gcd(abs(x2 - x1), abs(y2 - y1)) + 1;要注意我们求出的结果包括端点,所以会有三个三角形端点重复,每一条边-1即可,写代码时我直接省略了+1的步骤;

 

AC代码:

#include <bits/stdc++.h>
using namespace std;

int gcd(int a, int b) {
	if (a < b)
		swap(a, b);
	while (b != 0) {
		int temp = a % b;
		a = b;
		b = temp;
	}
	return a;
}

int main() {
	int n, m, p;
	scanf("%d%d%d", &n, &m, &p);
	int s = p * m / 2;
	int b = gcd(n, m) + gcd(abs(n - p), m) + p;
	printf("%d", s - b / 2 + 1);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值