1067 Sort with Swap(0, i) (25分)

121 篇文章 0 订阅
115 篇文章 0 订阅

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题解:

以下柳神的代码,真的强。

我一开始的思路一样,不过事实现方式过于冗余,最后陷入了死循环ORZ

一个数组搞定的事,我开了两个,逻辑比较混乱,导致最后一直交换同一个数。实在不想改bug了直接看题解。

#include <iostream>
#include <algorithm>

using namespace std;

int main() {
	int n, t, cnt = 0, a[100010];
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> t;
		a[t] = i;
	}
	for (int i = 1; i < n; i++)
	{
		if (i != a[i])//第i个位置不是正确位置
		{
			while (a[0] != 0)//0不在原位上,一直交换直到0回原位
			{
				swap(a[0], a[a[0]]);//交换0当前位置,与0当前应该放的数字的位置
				cnt++;
			}
			if (i != a[i]) {
				swap(a[0], a[i]);
				cnt++;
			}
		}
	}
	cout << cnt;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值